axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Inoguchi, Kinichiro" <Kinichiro.Inogu...@hp.com>
Subject RE: [Axis2][1.0] RPCMessageReceiver and javabeans array
Date Tue, 16 May 2006 13:53:17 GMT
Dims, 

I did it, as AXIS2-742.

Thanks,
kinichiro

-----Original Message-----
From: Davanum Srinivas [mailto:davanum@gmail.com] 
Sent: Tuesday, May 16, 2006 10:44 PM
To: axis-user@ws.apache.org
Subject: Re: [Axis2][1.0] RPCMessageReceiver and javabeans array


Kinichiro,

Please log a bug in JIRA and upload all the files.

thanks,
dims

On 5/16/06, Inoguchi, Kinichiro <Kinichiro.Inoguchi@hp.com> wrote:
> Hi,
>
> I'm testing RPCMessageReceiver with java class
> that receives array of javabeans and returns array of javabeans.
>
>         package test;
>         public class ArrayJavaBeans {
>                 public testServiceOut [] testService(testServiceIn []
> inParam) {
>                         testServiceOut [] outParam = new 
> testServiceOut[inParam.length];
>                         return outParam;
>                 }
>         }
>
> After deploy this service, I tried to generate proxy code from .NET, 
> but I got errors like these;
>
> The document at the url 
> http://localhost:8080/axis2/services/ArrayJavaBeans?wsdl was not 
> recognized as a known document type. The error message from each known

> type may help you fix the problem:
> - Report from 'WSDL Document' is 'There is an error in XML document 
> (1, 490).'.
>   - Invalid URI: The format of the URI could not be determined.
> - Report from 'DISCO Document' is 'Discovery document at the URL 
> http://localhost:8080/axis2/services/ArrayJavaBeans?wsdl could not be 
> found.'.
>   - The document format is not recognized.
> - Report from 'XML Schema' is 'Expected Schema root. Make sure that 
> the root element is <schema> and the namespace is 
> 'http://www.w3.org/2001/XMLSchema' for an XSD schema or 
> 'urn:schemas-microsoft-com:xml-data' for an XDR schema. An error 
> occurred at , (1, 2).'.
>
> It seems something wrong with WSDL generated by Axis2.
>
> Does anyone know about this problem ?
> Is there any way to avoid this trouble ?
>
> I attached sourcecode, services.xml and generated wsdl.
>
> Thanks,
> kinichiro
>
>
>
>


-- 
Davanum Srinivas : http://wso2.com/blogs/

Mime
View raw message