axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Throw Away" <throwawa...@gmail.com>
Subject WSDL2Java w/ XMLBeans - not generating some source files
Date Mon, 15 May 2006 21:54:12 GMT
Hello,

I am using the WSDL2Java command to generate some java files with the XML
Beans databinding. For some reason, some classes that I expect to be
generated don't come out. I have been using Axis2 v 0.93 and am now
upgrading to 1.0.

Here is a snippet of my WSDL:
<xs:include schemaLocation="common.xsd"/>
<xs:element name="ExportData" type="ExportDataType"/>

<xs:complexType name="ExportDataType">
  <xs:sequence>
     <xs:element name="Header" type="HeaderType"/>
     <xs:sequence>
      <xs:element name="Data" type="DataType"/>
     </xs:sequence>
  </xs:sequence>
</xs:complexType>

In the old version, I would get generated types for
ExportDataType
ExportDataDocument
HeaderType,
 and so on.
But now, I get no class for ExportDataDocument among others.
Some type classes get generated, but not the document.

This is the WSDL2Java I am calling from inside of ant:
        <java classname="org.apache.axis2.wsdl.WSDL2Java"
            failonerror="true" fork="true"
            classpathref="ws.classpath">
            <arg line="-uri ${wsdl.location}"/>
            <arg line="-ss"/>
            <arg line="-sd"/>
            <arg line="-d xmlbeans"/>
            <arg line="-o ${generated.dir}"/>
            <arg line="-g"/>
        </java>

Any help would be greatly appreciated.

Mime
View raw message