axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "GOBE HOBONA" <gehob...@hotmail.com>
Subject RE: got security module installation problems :(
Date Wed, 26 Apr 2006 00:06:18 GMT
There seems to be a problem with the wss4j jar file inside the 
security-0.95.mar file conflicting with the wss4j-SNAPHOT inside the WEB-INF 
folder.

To enable the security module to work, this is what I did:

1) Install all the jar files from the axis2-std-0.95-bin/samples/security 
into the WEB-INF/lib. SEE FOOTNOTE FOR LIST
2)Remove wss4j-SNAPSHOT.jar from WEB-INF/lib.
3)Then add xalan.jar to WEB-INF/lib       (using version 2.6.0 on JDK1.5)



4) If you wish to test the security module using the SecureService sample 
check out the message from
http://mail-archives.apache.org/mod_mbox/ws-axis-user/200603.mbox/%3c221167604BF72B49B5BD860E91045FD499C68A@mailserver01.BCIFOMENTO.CO.MZ%3e


Service.xml has this error <acionMapping>urn:echo</<acionMapping>   Notice

the endtag is erroneous.



FOOTNOTE:
axis2-std-0.95-bin.zip is the binary distribution from main Axis2 website
If you test the servicelister after step 2, you will get a message about a 
missing FuncLoader class. That's when you can add xalan.jar to your 
WEB-INF/lib folder.

Jar files in security sample folder include

   bcprov-jdk13-131.jar
   commons-discovery-0.2.jar
   secUtil.jar
   xmlsec-1.2.1.jar
   wss4j-SNAPSHOT.jar

Cheers,

Gobe Hobona



Mime
View raw message