axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Deepal Jayasinghe <dee...@opensource.lk>
Subject Re: [axis2] NPE after deploying servicegroups
Date Wed, 19 Apr 2006 07:50:39 GMT
can u pls send us the services archive file so that we can have a look
at that.

donnerdrummel2000-mailing@yahoo.de wrote:

>Hi, 
> 
>while trying to deploy some services as a servicegroup
>under 
>axis2-0.95-Snapshot, the result is allways to get this
>servicegroup listed as a 
>'Faulty Service' and in detail there is a NPE as
>follows: 
> 
>Error: java.lang.NullPointerException at 
>org.apache.axis2.deployment.DeploymentEngine.addServiceGroup(DeploymentEngine.java:195)
>at 
>org.apache.axis2.deployment.DeploymentEngine.doDeploy(DeploymentEngine.java:387)
>
>at 
>org.apache.axis2.deployment.repository.util.WSInfoList.update(WSInfoList.java:196)
>at 
>org.apache.axis2.deployment.listener.RepositoryListenerImpl.update(RepositoryListenerImpl.java:197)
>at 
>org.apache.axis2.deployment.listener.RepositoryListenerImpl.checkServices(RepositoryListenerImpl.java:147)
>
>at 
>org.apache.axis2.deployment.DeploymentEngine.load(DeploymentEngine.java:523)
>at 
>org.apache.axis2.deployment.FileSystemConfigurator.getAxisConfiguration(FileSystemConfigurator.java:59)
>at 
>org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContext(ConfigurationContextFactory.java:36)
>
>at 
>org.apache.axis2.context.ConfigurationContextFactory.createConfigurationContextFromFileSystem(ConfigurationContextFactory.java:52)
>at
> 
>org.apache.axis2.transport.http.AxisServlet.initConfigContext(AxisServlet.java:212)
>at 
>org.apache.axis2.transport.http.AxisServlet.init(AxisServlet.java:193)
>at 
>org.apache.catalina.core.StandardWrapper.loadServlet(StandardWrapper.java:1091)
>at 
>org.apache.catalina.core.StandardWrapper.allocate(StandardWrapper.java:750)
>at 
>org.apache.catalina.core.StandardWrapperValve.invoke(StandardWrapperValve.java:130)
>at 
>org.apache.catalina.core.StandardContextValve.invoke(StandardContextValve.java:178)
>at 
>org.apache.catalina.core.StandardHostValve.invoke(StandardHostValve.java:126)
>
>at 
>org.apache.catalina.valves.ErrorReportValve.invoke(ErrorReportValve.java:105)
>at 
>org.apache.catalina.core.StandardEngineValve.invoke(StandardEngineValve.java:107)
>at 
>org.apache.catalina.connector.CoyoteAdapter.service(CoyoteAdapter.java:148)
>at 
>org.apache.coyote.http11.Http11Processor.process(Http11Processor.java:868)
>at
> 
>org.apache.coyote.http11.Http11BaseProtocol$Http11ConnectionHandler.processConnection(Http11BaseProtocol.java:663)
>at 
>org.apache.tomcat.util.net.PoolTcpEndpoint.processSocket(PoolTcpEndpoint.java:527)
>at 
>org.apache.tomcat.util.net.LeaderFollowerWorkerThread.runIt(LeaderFollowerWorkerThread.java:80)
>
>at 
>org.apache.tomcat.util.threads.ThreadPool$ControlRunnable.run(ThreadPool.java:684)
>at java.lang.Thread.run(Thread.java:595) 
> 
>
>
>So what did I wrong? Deploing the services in the
>servicegroup via 
>single *.aar-archives doesn't cause any trouble, only
>the servicedeployment 
>via servicegroup fails...
>
>Thanks Ted
>
>
>		
>___________________________________________________________ 
>Telefonate ohne weitere Kosten vom PC zum PC: http://messenger.yahoo.de
>
>
>  
>

-- 
Thanks,
Deepal
................................................................
~Future is Open~ 



Mime
View raw message