axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Deepal Jayasinghe <dee...@opensource.lk>
Subject Re: [Axis2] 1.0RC1 module problems
Date Mon, 17 Apr 2006 10:39:11 GMT
hmm , sometimes ago we set the module as the name specified in
module.xml , but we changed that recently (0.95) to have module name as
name of the archive file.So previously module.xml had name="logging"
attribute and that become the name of the module even though actual
archive name LogingModule.mar , now the case is different and module
name always be the LogingModule

robert lazarski wrote:

> Hi all,
>
> I'm trying to port a module from around .94 to RC1 . I had some
> engagement problems, so I decided to try deploying the LoggingModule
> from the user guide - my module largely follows that example. The
> debug logs show:
>
> - Deploying module : LoggingModule
> - org.apache.axis2.i18n.resource::handleGetObject(modulenotavailble)
> - org.apache.axis2.i18n.resource::handleGetObject(modulevalfailed)
> - Module validation failed  Trying to engage a module which is not
> available : logging
> - org.apache.axis2.i18n.resource::handleGetObject(modulenotavailble)
> - org.apache.axis2.i18n.resource::handleGetObject(modulevalfailed)
> - Module validation failed  Trying to engage a module which is not
> available : logging
>
> Now the steps I followed was:
>
> 1) Move LoggingModule.mar to WEB-INF/modules.
> 2) add <module ref="logging"/> to my services.xml
> 3) Edit axis2.xml to put  <phase name="loggingPhase"/> in the inflow,
> outflow, and faults.
> 4) add <module ref="logging"/> to axis2.xml .
>
> That's the way I remember it working. Any ideas?
>
> Robert
> http://www.braziloutsource.com/
>

-- 
Thanks,
Deepal
................................................................
~Future is Open~ 



Mime
View raw message