axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Dies Koper <d...@jp.fujitsu.com>
Subject Re: SAAJ1.2 support in Axis
Date Tue, 11 Apr 2006 02:21:38 GMT
Hello Hendrik,

Axis 1.2.1 and Axis 1.3 definitely support SAAJ 1.2. I suppose Axis 1.2 
does too and earlier versions do not, but I'm just guessing.
If the old versions are still available for download, maybe you could 
check yourself (and post a matrix here or even add it to the Axis Wiki).

Regards,
Dies


Hendrik Schreiber wrote:
> Hi everyone,
> 
> If anyone could tell me, which version of axis supports saaj 1.2 (SOAP
> with Attachments API for Java Specification), it would be very helpful
> for me, since that is the version required by J2EE 1.4.
> 
> I searched the axis website, but there does not seem to be such a thing
> as a compatibility matrix.
> 
> Thanks a lot!
> 
> -hendrik
> 
>> -----Original Message-----
>> From: Hendrik Schreiber 
>> Sent: Friday, March 31, 2006 4:43 PM
>> To: 'axis-user@ws.apache.org'
>> Cc: David Ingbretsen
>> Subject: RE: Which Axis for WebLogic 9.1?
>>
>> Supposedly WebLogic 9.0/9.1 fully support J2EE 1.4. 
>>
>>> -----Original Message-----
>>> From: Hendrik Schreiber [mailto:hendrik.schreiber@datastream.net]
>>> Sent: Friday, March 31, 2006 4:23 PM
>>> To: axis-user@ws.apache.org
>>> Cc: David Ingbretsen
>>> Subject: RE: Which Axis for WebLogic 9.1?
>>>
>>> Lars,
>>>
>>> Yeah - the problem is definitely similar, which is why I'd like to 
>>> find 'matching' versions. I.e. which version of Axis does play well 
>>> with WebLogic 9.1 - if there is one at all that does that.
>>>
>>> We compared filesizes etc and concluded that the 
>> webservices.jar that 
>>> ships with 9.1 is a different one than the one shipping 
>> with 8.1. So 
>>> the problem is similar, but not the same.
>>>
>>> -hendrik
>>>
>>>> -----Original Message-----
>>>> From: Lars Torunski [mailto:ltorunski@t-online.de]
>>>> Sent: Friday, March 31, 2006 4:19 PM
>>>> To: axis-user@ws.apache.org
>>>> Subject: Re: Which Axis for WebLogic 9.1?
>>>>
>>>> Maybe you have a similar problem compared to
>>>> http://ws.apache.org/axis/java/install.html#WebLogic8.1
>>>>
>>>> WebLogic 8.1 ships with webservices.jar that conflicts with Axis' 
>>>> saaj.jar and prevents Axis 1.2 from working right out of
>>> the box. This
>>>> conflict exists because WebLogic uses an older definition of
>>>> javax.xml.soap.* package from Java Web Services Developer
>>> Pack Version
>>>> 1.0 <http://java.sun.com/webservices/docs/1.0/api/javax/xml/soap>,
>>>> whereas Axis uses a newer revision from J2EE 1.4.
>>>>
>>>> Hendrik Schreiber wrote:
>>>>> Hey,
>>>>>
>>>>> We are currently upgrading from WebLogic 8.1 to 9.1 and
>>> one of the
>>>>> things that stopped working is Axis 1.1.
>>>>>
>>>>> We are seeing the following NullPointerException in the
>>> Call class:
>>>>> java.lang.NullPointerException
>>>>>         at org.apache.axis.client.Call.invoke(Call.java:1768)
>>>>>         at
>>>>>
>> com.dstm.mp.businessprocess.base.AdvReportClient.sendMessage(AdvReport
>>>>> Client.java:738)
>>>>>
>>>>>         at
>>>>>
>> com.dstm.mp.businessprocess.base.AdvReportClient.logon(AdvReportClient
>>>>> .java:255)
>>>>>
>>>>> <...>
>>>>>
>>>>> Apparently this is linked to WebLogic prefering its own
>>>> saaj classes. 
>>>>> In fact when we prepend the saaj jar that comes with Axis
>>>> 1.1 to the
>>>>> WebLogic classpath, things work out. However, that is
>>> unfortunately
>>>>> not an option for us.
>>>>>
>>>>> So what I was wondering is the following:
>>>>>
>>>>> - Has anyone figured out what's the best way to get Axis
>>> (preferably
>>>>> 1.1) to run with WebLogic 9.1?
>>>>> - Is there a version of Axis that works smoothly with
>>> WebLogic 9.1?
>>>>> - Which saaj version comes with Axis 1.1, 1.2, 1.2.1 and 1.3?
>>>>>
>>>>> Thanks for your help!
>>>>>
>>>>> -hendrik


Mime
View raw message