axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Davanum Srinivas" <dava...@gmail.com>
Subject Re: [Axis2-0.94] service deploy fails when ports bound to SOAP 1.2 in WSDL
Date Wed, 05 Apr 2006 15:09:18 GMT
This has been fixed in latest SVN :)

-- dims

On 4/5/06, Andreas Bobek <andreas.bobek@uni-rostock.de> wrote:
>
> Both, code generation and deploying of WSDL 1.1 / SOAP 1.2 services is now
> working in 0.95 :-)
>
> BUT,
>
> if I use AxisService.printWSDL(OutputStream out, String requestIP)
> I get a WSDL with SOAP 1.1 binding!
> Furthermore, if there is no SOAP 1.1 namespace declared in the original WSDL
> file, I get an exception
>
> WSDLException: faultCode=OTHER_ERROR: Can't find prefix for
> 'http://schemas.xmlsoap.org/wsdl/soap/'. Namespace prefixes must be set on
> the Definition object using the addNamespace(...) method.:
>         at
> org.apache.axis2.description.AxisService.printUsingWSDLDefinition(AxisServic
> e.java:497)
>         at
> org.apache.axis2.description.AxisService.printWSDL(AxisService.java:427)
> ...
>
>
> I suppose this a limitation of WSDL4J ?
>
> Just for info,
> Andreas Bobek.
>
>
>
> > -----Ursprüngliche Nachricht-----
> > Von: Deepal Jayasinghe [mailto:deepal@opensource.lk]
> > Gesendet: Dienstag, 28. März 2006 06:16
> > An: axis-user@ws.apache.org
> > Betreff: Re: [Axis2-0.94] service deploy fails when ports
> > bound to SOAP 1.2 in WSDL
> >
> > oh I didnt know that :(
> >
> > Davanum Srinivas wrote:
> >
> > >Deepal,
> > >
> > >Already fixed :) see http://tinyurl.com/jy8mz fix should be in 0.95.
> > >
> > >-- dims
> > >
> > >On 3/26/06, Deepal Jayasinghe <deepal@opensource.lk> wrote:
> > >
> > >
> > >>yes , thats a bug in Axis2 and we will fix that before 1.0.
> > >>
> > >>Andreas Bobek wrote:
> > >>
> > >>
> > >>
> > >>>Hi,
> > >>>
> > >>>I have a WSDL file with a binding to SOAP 1.2 only, e.g. I use
> > >>>
> > >>>xmlns:soap12="http://schemas.xmlsoap.org/wsdl/soap12/" instead of
> > >>>xmlns:soap11="http://schemas.xmlsoap.org/wsdl/soap/"
> > >>>
> > >>>Code generation works well.
> > >>>Deploying with bindings to SOAP 1.1 works well, too.
> > >>>
> > >>>But when bind to SOAP 1.2 I get follow exception:
> > >>>
> > >>>org.apache.wsdl.impl.WSDLProcessingException: no port with soap
> > >>>binding found
> > >>>       at
> > >>>org.apache.axis2.deployment.AxisServiceBuilder.getAxisServi
> > ce(AxisSer
> > >>>viceBui
> > >>>lder.java:219)
> > >>>       at
> > >>>org.apache.axis2.deployment.AxisServiceBuilder.getAxisServi
> > ce(AxisSer
> > >>>viceBui
> > >>>lder.java:127)
> > >>>       at
> > >>>org.apache.axis2.deployment.repository.util.ArchiveReader.p
> > rocessWSDL
> > >>>File(Ar
> > >>>chiveReader.java:267)
> > >>>       at
> > >>>org.apache.axis2.deployment.repository.util.ArchiveReader.p
> > rocessWSDL
> > >>>s(Archi
> > >>>veReader.java:333)
> > >>>       at
> > >>>org.apache.axis2.deployment.DeploymentEngine.doDeploy(Deplo
> > ymentEngine.java:
> > >>>383)
> > >>>..
> > >>>
> > >>>which I think means WSDL-SOAP 1.2 is not known.
> > >>>
> > >>>Debugging inside AxisServiceBuilder:
> > >>>javax.wsdl.extensions.UnknownExtensibilityElement
> > >>>UnknownExtensibilityElement
> > >>>({http://schemas.xmlsoap.org/wsdl/soap12/}binding)
> > >>>
> > >>>Is this a limitation in Axis up to now?
> > >>>
> > >>>Thank you, Andreas Bobek.
> > >>>
> > >>>
> > >>>
> > >>>
> > >>>
> > >>>
> > >>>
> > >>--
> > >>Thanks,
> > >>Deepal
> > >>................................................................
> > >>~Future is Open~
> > >>
> > >>
> > >>
> > >>
> > >>
> > >>
> > >
> > >
> > >--
> > >Davanum Srinivas : http://wso2.com/blogs/
> > >
> > >
> > >
> > >
> >
> > --
> > Thanks,
> > Deepal
> > ...............................................................
> > ~Future is Open~
> >
> >
>
>


--
Davanum Srinivas : http://wso2.com/blogs/

Mime
View raw message