axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Anne Thomas Manes" <atma...@gmail.com>
Subject Re: problem in accessing python Hello World Service
Date Sun, 26 Mar 2006 18:42:54 GMT
Do you know what message the Pyhton service is expecting?
My guess is that it isn't expecting you to send the method name in the
message.

Anne

On 3/25/06, Kashif Saleem <Kashif.Saleem@newcastle.ac.uk> wrote:
>
> Hi Anne,
>         Thanks for your response.I am attaching with this mail the
> HelloWorld Service and axis2 client.Its a simple HelloWorld service and I
> am using end point reference to access this service.There is no wsdl for
> it.
>
> Kind Regards
> Kashif Saleem
>
>
> -----Original Message-----
> From: Anne Thomas Manes [mailto:atmanes@gmail.com]
> Sent: Sat 3/25/2006 3:45 PM
> To: axis-user@ws.apache.org
> Subject: Re: problem in accessing python Hello World Service
>
> Please post the WSDL.
>
> Based on the error messages, I'm guessing that the server is not expecting
> the
>
> <example1:HelloWorld xmlns:example1="http://example1.org/example1">
>
> element to appear in the message.
>
> Anne
>
> On 3/24/06, Kashif Saleem <Kashif.Saleem@newcastle.ac.uk> wrote:
> >
> > Hi all,
> >        I installed a ZSI 2.0_rc2  on machine geron045.ncl.ac.uk.I run
> the
> > HelloWorld.py service on  the this machine i.e.
> > http://geron045.ncl.ac.uk:8088/HelloWorld.py.This service has one
> > operation called "HelloWorld" which accepts one argument and return this
> > argument.
> >
> > Then from the another machine i.e "geron007.ncl.ac.uk" I tried to access
> > this HelloWorld service which is deployed at
> > http://geron045.ncl.ac.uk:8088/HelloWorld.py through AXIS2 client.I got
> > the processed failure message.I monitor the soap messages going back and
> > forth through TCPMON.The output for this is given below:
> >
> > Request:
> >
> > POST /HelloWorld.py HTTP/1.1
> >
> > User-Agent: Axis/2.0
> >
> > SOAPAction:
> >
> > Connection: Keep-Alive
> >
> > Host: geron045.ncl.ac.uk:8082
> >
> > Content-Length: 809
> >
> > Content-Type: text/xml; charset=UTF-8
> >
> >
> > <?xml version='1.0' encoding='UTF-8'?>
> > <soapenv:Envelope xmlns:soapenv="
> http://schemas.xmlsoap.org/soap/envelope/"
> > xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing">
> > <soapenv:Header><wsa:To xmlns:wsa="
> > http://schemas.xmlsoap.org/ws/2004/08/addressing">
> > http://localhost:8082/HelloWorld.py</wsa:To><wsa:ReplyTo xmlns:wsa="
> > http://schemas.xmlsoap.org/ws/2004/08/addressing"><wsa:Address>
> > http://schemas.xmlsoap.org/ws/2004/08/addressing/role/anonymous
> </wsa:Address></wsa:ReplyTo><wsa:MessageID
> > xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing
> > ">0A2F12FAE0A1B8456E11432354035971</wsa:MessageID>
> > </soapenv:Header>
> > <soapenv:Body>
> > <example1:HelloWorld xmlns:example1="http://example1.org/example1">
> > <example1:Text>Axis2 Echo String </example1:Text>
> > </example1:HelloWorld>
> > </soapenv:Body>
> > </soapenv:Envelope>
> >
> > Response:
> >
> > HTTP/1.0 500 Internal error
> >
> > Server: ZSI/1.1 BaseHTTP/0.3 Python/2.4.2
> >
> > Date: Fri, 24 Mar 2006 21:21:05 GMT
> >
> > Content-type: text/xml; charset="utf-8"
> >
> > Content-Length: 695
> >
> > <SOAP-ENV:Envelope xmlns:SOAP-ENC="
> > http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="
> > http://schemas.xmlsoap.org/soap/envelope/" xmlns:ZSI="
> > http://www.zolera.com/schemas/ZSI/" xmlns:xsd="
> > http://www.w3.org/2001/XMLSchema" xmlns:xsi="
> > http://www.w3.org/2001/XMLSchema-instance">
> > <SOAP-ENV:Header>
> > </SOAP-ENV:Header>
> > <SOAP-ENV:Body>
> > <SOAP-ENV:Fault>
> > <faultcode>SOAP-ENV:Server
> > </faultcode>
> > <faultstring>Processing Failure</faultstring><detail><ZSI:FaultDetail>
> > <ZSI:string>exceptions:TypeError
> > Expecting typecode in result
> > </ZSI:string>
> >
> >
> <ZSI:trace>/usr/lib/python2.4/site-packages/ZSI/dispatch.py:69:_Dispatch</ZSI:trace></ZSI:FaultDetail>
> > </detail>
> > </SOAP-ENV:Fault>
> > </SOAP-ENV:Body>
> > </SOAP-ENV:Envelope>
> >
> > Just to clarify things further.I did one more thing,I removed the
> argument
> > for the HelloWorld operation so now it is accepting no argument.And now
> > when I tried to access the same service.I got the error
> again.Bymonitoring the soap messages going back and forth through
> > TCPMON.This type the error changes to something else as given below:
> >
> >
> > Request:
> >
> > POST /HelloWorld.py HTTP/1.1
> >
> > User-Agent: Axis/2.0
> >
> > SOAPAction:
> >
> > Connection: Keep-Alive
> >
> > Host: geron045.ncl.ac.uk:8082
> >
> > Content-Length: 740
> >
> > Content-Type: text/xml; charset=UTF-8
> >
> > <?xml version='1.0' encoding='UTF-8'?>
> > <soapenv:Envelope xmlns:soapenv="
> http://schemas.xmlsoap.org/soap/envelope/"
> > xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing">
> > <soapenv:Header>
> > <wsa:To xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing">
> > http://localhost:8082/HelloWorld.py</wsa:To>
> > <wsa:ReplyTo xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing
> > "><wsa:Address>
> > http://schemas.xmlsoap.org/ws/2004/08/addressing/role/anonymous
> </wsa:Address></wsa:ReplyTo><wsa:MessageID
> > xmlns:wsa="http://schemas.xmlsoap.org/ws/2004/08/addressing
> > ">C1EB5D8FA2D3E2ABE811432360408471</wsa:MessageID>
> > </soapenv:Header>
> > <soapenv:Body>
> > <example1:HelloWorld xmlns:example1="http://example1.org/example1" />
> > </soapenv:Body>
> > </soapenv:Envelope>
> >
> >
> > Response:
> >
> > HTTP/1.0 500 Internal error
> >
> > Server: ZSI/1.1 BaseHTTP/0.3 Python/2.4.2
> >
> > Date: Fri, 24 Mar 2006 21:31:42 GMT
> >
> > Content-type: text/xml; charset="utf-8"
> >
> > Content-Length: 708
> >
> >
> > <SOAP-ENV:Envelope xmlns:SOAP-ENC="
> > http://schemas.xmlsoap.org/soap/encoding/" xmlns:SOAP-ENV="
> > http://schemas.xmlsoap.org/soap/envelope/" xmlns:ZSI="
> > http://www.zolera.com/schemas/ZSI/" xmlns:xsd="
> > http://www.w3.org/2001/XMLSchema" xmlns:xsi="
> > http://www.w3.org/2001/XMLSchema-instance">
> > <SOAP-ENV:Header>
> > </SOAP-ENV:Header>
> > <SOAP-ENV:Body>
> > <SOAP-ENV:Fault>
> > <faultcode>SOAP-ENV:Server</faultcode>
> > <faultstring>Processing Failure</faultstring>
> > <detail>
> > <ZSI:FaultDetail>
> > <ZSI:string>exceptions:TypeError
> > HelloWorld() takes no arguments (1 given)
> > </ZSI:string>
> > <ZSI:trace>/usr/lib/python2.4/site-packages/ZSI/dispatch.py:67:_Dispatch
> > </ZSI:trace>
> > </ZSI:FaultDetail>
> > </detail>
> > </SOAP-ENV:Fault>
> > </SOAP-ENV:Body>
> > </SOAP-ENV:Envelope>
> >
> >
> > I am quite surprised by these errors.I am attaching with this mail my
> > HelloWorld.py service and AXIS2 client code.I would appreciate if some
> guy
> > would explain me the strange behavior of this simple scenario.
> >
> >
> > Kind Regards
> > Kashif Saleem
> >
> >
> >
> >
> >
> >
>
>
>
>
>
>

Mime
View raw message