axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Ali Sadik Kumlali <as_kuml...@yahoo.com>
Subject [Axis2] - 0.95 - Couldn't get security sample to work
Date Thu, 23 Mar 2006 08:19:43 GMT
Hi all,

Since I'm told that security sample problems shown in 0.94 would be fixed in 0.95, I checked
out the latest source from SVN and ran the Maven.

Although I had many problems such as SVN checkout failure, Maven build, etc.,  I  could finally
manage to have jar and mar files. 

I ran security sample and got the following error:

----------------
securitySample:
     [java] org.apache.axis2.AxisFault: WSHandler: Signature: error during messa
ge procesingorg.apache.ws.security.WSSecurityException: General security error (
WSEncryptBody/WSSignEnvelope: Element to encrypt/sign not found: http://www.w3.o
rg/2005/08/addressing, To); nested exception is:
     [java]     org.apache.ws.security.WSSecurityException: WSHandler: Signature
: error during message procesingorg.apache.ws.security.WSSecurityException: Gene
ral security error (WSEncryptBody/WSSignEnvelope: Element to encrypt/sign not fo
und: http://www.w3.org/2005/08/addressing, To)
     [java]     at org.apache.axis2.security.WSDoAllSender.invoke(WSDoAllSender.
java:253)

...
--------------

It seemed that security module started before addressing and thus there were no  addressing
related tags in soap header. I, then, commented <module ref="security"/>  out and ran
the sample again. This time it directly established a connection to the server without a console
log that says "[java] - Deploying module : addressing". Consequently, I thought there was
a problem related to the loading or executing of addressing module. Or I did something wrong
:(

Does anybody have the same problem?

Thanks a lot,

Ali Sadik Kumlali

		
---------------------------------
Blab-away for as little as 1ยข/min. Make  PC-to-Phone Calls using Yahoo! Messenger with Voice.
Mime
View raw message