axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Andreas Bobek <andreas.bo...@uni-rostock.de>
Subject [Axis2-0.94] service deploy fails when ports bound to SOAP 1.2 in WSDL
Date Fri, 24 Mar 2006 16:49:39 GMT
Hi,

I have a WSDL file with a binding to SOAP 1.2 only, e.g. I use

xmlns:soap12="http://schemas.xmlsoap.org/wsdl/soap12/" instead of
xmlns:soap11="http://schemas.xmlsoap.org/wsdl/soap/"

Code generation works well.
Deploying with bindings to SOAP 1.1 works well, too.

But when bind to SOAP 1.2 I get follow exception:

org.apache.wsdl.impl.WSDLProcessingException: no port with soap binding
found
        at
org.apache.axis2.deployment.AxisServiceBuilder.getAxisService(AxisServiceBui
lder.java:219)
        at
org.apache.axis2.deployment.AxisServiceBuilder.getAxisService(AxisServiceBui
lder.java:127)
        at
org.apache.axis2.deployment.repository.util.ArchiveReader.processWSDLFile(Ar
chiveReader.java:267)
        at
org.apache.axis2.deployment.repository.util.ArchiveReader.processWSDLs(Archi
veReader.java:333)
        at
org.apache.axis2.deployment.DeploymentEngine.doDeploy(DeploymentEngine.java:
383)
..

which I think means WSDL-SOAP 1.2 is not known.

Debugging inside AxisServiceBuilder:
javax.wsdl.extensions.UnknownExtensibilityElement
UnknownExtensibilityElement
({http://schemas.xmlsoap.org/wsdl/soap12/}binding)

Is this a limitation in Axis up to now?

Thank you, Andreas Bobek.


Mime
View raw message