axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Gedas A" <lek...@gmail.com>
Subject Re: axis on Sun Application Server 8.2
Date Wed, 22 Feb 2006 11:02:01 GMT
Even when I add activation.jar and mail.jar to my classpath to eliminate the
warning I get while deploying web service I still get the same fault.

On 2/21/06, Gedas A <lektuv@gmail.com> wrote:
>
> Hello,
>
> I deployed axis 1.3 on Sun App Server 8.2. I granted the following
> permissions in order to get it running:
>
> ==================
> grant {
>     permission java.lang.RuntimePermission "getClassLoader";
>     permission java.lang.RuntimePermission "createClassLoader";
>     permission java.net.SocketPermission "*", "connect,accept,resolve";
>     permission java.io.FilePermission "<>", "read,write,delete";
>     permission java.util.PropertyPermission "user.language", "write";
>     permission javax.management.MBeanPermission "
> org.apache.commons.modeler.BaseModelMBean#-[axis:type=server]",
> "registerMBean";
>     permission javax.management.MBeanPermission "
> org.apache.commons.modeler.BaseModelMBean#-[axis:type=deploy]",
> "registerMBean";
>     permission javax.management.MBeanPermission "
> org.apache.commons.modeler.BaseModelMBean#- [axis:type=query]",
> "registerMBean";
> };
> ==================
>
> Validation page is happy.
> But when I try to deploy a web service I get:
> ==================
> $ java org.apache.axis.client.AdminClient deploy.wsdd
> 2006.2.21 15.45.17 org.apache.axis.utils.JavaUtils isAttachmentSupported
> WARNING: Unable to find required classes (javax.activation.DataHandler and
> javax.mail.internet.MimeMultipart). Atta
> chment support is disabled.
> Processing file deploy.wsdd
> Exception: AxisFault
>  faultCode: {
> http://schemas.xmlsoap.org/soap/envelope/}Server.userException<http://schemas.xmlsoap.org/soap/envelope/%7DServer.userException>
>  faultSubcode:
>  faultString: java.lang.reflect.InvocationTargetException
>  faultActor:
>  faultNode:
>  faultDetail:
>         {http://xml.apache.org/axis/}hostname:gedas<http://xml.apache.org/axis/%7Dhostname:gedas>
> ==================
>
> Application server log says:
> [#|2006-02-21T15:45:
> 18.359+0200|INFO|sun-appserver-pe8.2|javax.enterprise.system.stream.out|_ThreadID=11;|-
> Unable to find config file.  Creating new servlet engine config file:
> /WEB-INF/server- config.wsdd
> |#]
>
> I checked the server-config.wsdd file. The entry for my web service is
> there but there is no entry in list of the web services in the axis webapp.
>
> Everything works on Tomcat 5.5.15, using the same wsdl, wsdd and web
> services code.
>
> Am I missing something?
>
> --
> Gedas
>

Mime
View raw message