axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From <ge...@etixpert.com>
Subject HTTP Error 401 when deploying wsdd
Date Mon, 20 Feb 2006 12:29:46 GMT
Hallo!

 The things was working already, and once when I tried to deploy my wsdd,
I got the authorization error below. I have no <security-constraint> in
my web.xml, and didn't change anything in axis configuration.
How can I turn off this authorization function? OR What could be the reason?

Thnx
 George


....axis.client.AdminClient -p 8085 deploy.wsdd
log4j:WARN No appenders could be found for logger
(org.apache.axis.i18n.ProjectR
esourceBundle).
log4j:WARN Please initialize the log4j system properly.
Processing file deploy.wsdd
Exception: AxisFault
 faultCode: {http://xml.apache.org/axis/}HTTP
 faultSubcode:
 faultString: (401)Unauthorized
 faultActor:
 faultNode:
 faultDetail:
        {}:return code:  401
&lt;?xml version=&quot;1.0&quot;
encoding=&quot;utf-8&quot;?&gt;&lt;soapenv:Enve
lope xmlns:soapenv=&quot;http://schemas.xmlsoap.org/soap/envelope/&quot;
xmlns:x
sd=&quot;http://www.w3.org/2001/XMLSchema&quot;
xmlns:xsi=&quot;http://www.w3.or
g/2001/XMLSchema-instance&quot;&gt;&lt;soapenv:Body&gt;&lt;soapenv:Fault&gt;&lt;
faultcode
xmlns:ns1=&quot;http://xml.apache.org/axis/&quot;&gt;ns1:Server.Unauth
enticated&lt;/faultcode&gt;&lt;faultstring&gt;User 'admin' not
authenticated&lt;
/faultstring&gt;&lt;detail&gt;&lt;ns2:hostname
xmlns:ns2=&quot;http://xml.apache
.org/axis/&quot;&gt;suvi&lt;/ns2:hostname&gt;&lt;/detail&gt;&lt;/soapenv:Fault&g
t;&lt;/soapenv:Body&gt;&lt;/soapenv:Envelope&gt;
        {http://xml.apache.org/axis/}HttpErrorCode:401




Mime
View raw message