axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From robert <robertlazar...@gmail.com>
Subject Re: problems with initial Axis installation.
Date Thu, 16 Feb 2006 19:28:13 GMT
Just a minor correction - don't move tools.jar anywhere. Its part of the jdk - 
on my system the only place its at is /usr/local/jdk1.5.0_03/lib/tools.jar . 

With the proper JAVA_HOME and perhaps CATALINA_HOME environment vars set, java 
and tomcat will be able to find your imports just fine. The latest tomcats 
may also want JRE_HOME set. Trying to be helpful, that all comes down to 
(note, I'm not a windows user): 

JAVA_HOME=/usr/local/jdk1.5.0_03
JRE_HOME=/usr/local/jdk1.5.0_03/jre
CATALINA_HOME=/home/iksrazal/tomcat

HTH,
Robert 
http://www.braziloutsource.com/

Em Quinta 16 Fevereiro 2006 18:08, o Jim Azeltine escreveu:
> You said it yourself!
>   "I searched my system for tools.jar and so I copied the one I have in
> c:\j2dsk1.4.2_10\lib to axis\WEB-INF\lib "
>
>   Then your error said:
> :Invalid class file format in C:\Program
> : Files\Java\jre1.5.0_06\lib\rt.jar(java/util/Enumeration.class)."
>
>   Do you see it? You have two different versions of Java in play.
>   The next thing is that the correct version of tools.jar needs to go in
> the Tomcat/common/lib directory, not axis. Make sense now? 8)
>
>   HTH!
>
>   Jim
> Jim Strathmeyer <jim.strathmeyer@tetratech-ffx.com> wrote:
>                 So I have Axis set up under Tomcat on WinXP. I’m not very
> experienced with Tomcat, MS Windows, or Java, but still very experienced
> with computers. I’m having some huge problems setting up axis.
>
>   First off, when I load
> http://localhost:8080/axis/EchoHeaders.jws?method=list I would get a
> “tools.jar: file not found” error. I searched my system for tools.jar and
> so I copied the one I have in c:\j2dsk1.4.2_10\lib to axis\WEB-INF\lib and
> I get the faultstring “Error while compiling:  C:\Program Files\Tomcat
> 5.5\webapps\axis\WEB-INF\jwsClasses\EchoHeaders.java”, and the errors
> starts out to say: “Error compiling C:\Program Files\Tomcat
> 5.5\webapps\axis\WEB-INF\jwsClasses\EchoHeaders.java: Line 0, column 0:
> could not parse error message:  Note: sun.tools.javac.Main has been
> deprecated. error: Invalid class file format in C:\Program
> Files\Java\jre1.5.0_06\lib\rt.jar(java/util/Enumeration.class).  The
> major.minor version '49.0' is too recent for this tool to understand.
> C:\Program Files\Tomcat
> 5.5\webapps\axis\WEB-INF\jwsClasses\EchoHeaders.java:22: Class
> java.util.Enumeration not found in import.”
>
>   Second, in the userguide I am trying to run the test client under the
> heading “Consuming Web Services with Axis: Basics – Getting Started”. If I
> go into the axis-classes directory and type ‘java
> samples.userguide.example1.TestClient’ I get “Exception in thread "main"
> java.lang.NoClassDefFoundError: org/apache/axis/client/Service at
> samples.userguide.example1.TestClient.main(TestClient.java:31)”.
>
>   However, if I go into the samples\userguide\example1 directory and type
> “java TestClient” I get the following error:
>
>   Exception in thread "main" java.lang.NoClassDefFoundError: TestClient
> (wrong name: samples/userguide/example1/TestClient) at
> java.lang.ClassLoader.defineClass0(Native Method)
>           at java.lang.ClassLoader.defineClass(Unknown Source)
>           at java.security.SecureClassLoader.defineClass(Unknown Source)
>           at java.net.URLClassLoader.defineClass(Unknown Source)
>           at java.net.URLClassLoader.access$100(Unknown Source)
>           at java.net.URLClassLoader$1.run(Unknown Source)
>           at java.security.AccessController.doPrivileged(Native Method)
>           at java.net.URLClassLoader.findClass(Unknown Source)
>           at java.lang.ClassLoader.loadClass(Unknown Source)
>           at sun.misc.Launcher$AppClassLoader.loadClass(Unknown Source)
>           at java.lang.ClassLoader.loadClass(Unknown Source)
>           at java.lang.ClassLoader.loadClassInternal(Unknown Source)
>
>   Any idea how I can figure out how to fix these problems?

-- 

Mime
View raw message