axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Stijn Christiaens <stijn.christia...@vub.ac.be>
Subject Re: Axis problem
Date Wed, 11 Jan 2006 15:42:19 GMT
Thanks for the quick reply. Unfortunately, my server log is not showing
anything, but I will drill down a little deeper in the loglevels.
Fingers crossed.

On Wed, 2006-01-11 at 10:34 -0500, Frank wrote:
> Check the server log. Probably a classpath issue or something. Have had 
> similar problem and recall that being the problem
> 
> Stijn Christiaens wrote:
> 
> >Hello everyone,
> >
> >I am looking for some help on Axis.
> >I've created a wsdd file that auto-starts my webservice:
> >
> ><deployment xmlns="http://xml.apache.org/axis/wsdd/"
> >            xmlns:java="http://xml.apache.org/axis/wsdd/providers/java">
> >
> > <service name="Calculateur" provider="java:RPC">
> >  <parameter name="className"
> >value="vub.starlab.portal.pages.webservices.Calculator"/>
> >  <parameter name="allowedMethods" value="*"/>
> > </service>
> > 
> ></deployment>
> >
> >When I access the address for the service, it says that there is an Axis
> >service present (woohoo!), but when I go to the AxisServlet and ask for
> >the WSDL it says it cannot generate it (not so woohoo!).
> >
> >So in the next try I added a wsdlFile parameter to the wsdd in which I
> >placed a java2WSDL created wsdl file (for the Calculator class). Still
> >Axis tells me the service is present, but that it cannot generate the
> >wsdl file.
> >
> >However on the url .../services/Calculateur it says there is a web
> >service, but on the wsdl url .../services/Calculateur?wsdl it says it
> >cannot generate a wsdl file, because there is no web service at the
> >address.
> >
> >Am I doing something wrong?
> >
> >Thanks in advance for all the assistance!
> >
> >Ciao,
> >
> >Stijn
> >
> >
> >
> >  
> >
> 
> 


Mime
View raw message