axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Benjamin Drasin" <livingla...@hotmail.com>
Subject ?wsdl links not working on service list page
Date Wed, 21 Dec 2005 01:32:03 GMT
Hello,

Please excuse me if this is covered somewhere; I looked in the 
documentation, in the mail archive, and on the wiki and could not find 
anything promising.

I have written some web services (which are working).  Here is my web.xml:

...
...
    <servlet>
        <servlet-name>AxisServlet</servlet-name>
        <display-name>Apache-Axis Servlet</display-name>
        <servlet-class>
            org.apache.axis.transport.http.AxisServlet
        </servlet-class>
    </servlet>

    <servlet-mapping>
      <servlet-name>AxisServlet</servlet-name>
      <url-pattern>/services/*</url-pattern>
    </servlet-mapping>
...
...

I then added the file server-config.wsdd with my web services:

...
<service name="urn:mavent.review.asynchronous.poll" provider="java:RPC">
  <parameter name="allowedMethods" value="reviewDocument"/>
  <parameter name="className"
value="com.inventigo.mavent.comply.expert.portal.web.service.AsyncReview"/>
</service>
<service name="urn:mavent.review.view" provider="java:RPC">
  <parameter name="allowedMethods" value="getReviewResult"/>
  <parameter name="className"
value="com.inventigo.mavent.comply.expert.portal.web.service.GetReviewResult
"/>
</service>
...
...

  The URL http://localhost/app/services now lists my web services (and the 
web services work with the client I wrote), but the links lead to 404 error 
pages - is there another step I need to publish the wsdl files or something?

Thanks in advance

Bye-Ben



Mime
View raw message