axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Frank <fg...@optonline.net>
Subject [Fwd: Custom deploy version not working, instant works]
Date Thu, 29 Dec 2005 21:33:03 GMT
I'm sorry I missed that the SoapBindingStub had a static method that was 
executed the line with ===> is the line it just stops at, no exception 
thrown either at the server, but the bogus one at the client that is 
useless is thrown.

   private static void _initOperationDesc1(){
      try{
        org.apache.axis.description.OperationDesc oper;
        org.apache.axis.description.ParameterDesc param;
        oper = new org.apache.axis.description.OperationDesc();
        oper.setName("callObjectManager");
        param = new org.apache.axis.description.ParameterDesc(new javax.xml.
            namespace.QName("", "requestDoc"),
            org.apache.axis.description.ParameterDesc.IN,
                           new javax.xml.namespace.
                           QName("http://xml.apache.org/xml-soap", 
"Document"),
                           org.w3c.dom.Document.class, false, false);
        oper.addParameter(param);
        oper.setReturnType(new javax.xml.namespace.QName(
            "http://xml.apache.org/xml-soap", "Document"));
        oper.setReturnClass(org.w3c.dom.Document.class);
        oper.setReturnQName(new javax.xml.namespace.QName("",
            "callObjectManagerReturn"));
===>        oper.setStyle(org.apache.axis.constants.Style.RPC);
        oper.setUse(org.apache.axis.constants.Use.ENCODED);
        _operations[0] = oper;

    }





-------- Original Message --------
Subject: 	Custom deploy version not working, instant works
Date: 	Thu, 29 Dec 2005 15:22:53 -0500
From: 	Frank <fgeck@optonline.net>
Organization: 	Keyway Security
To: 	axis <axis-user@ws.apache.org>



I have 2 services where one service calls the other. I initially used 
instant deployment and it works fine.  Now I tried to switch to using 
custom deployment using the wsdd files.  Now it seems to have deployed 
but when the one service calls the other service I get a bogus useless 
exception at the client.  Nothing really useful is thrown at the server 
side either.  (using tomcat 5.0.29).  Started to put trace statements in 
the generated stub code.   As far as I can tell it executes this line 
and must fail some how to the client get the exception back but nothing 
is thrown at the service level, why?  I even but a catchall exception 
just in case as it only caught org.apache.axis.AxisFault but nothing.

Line from the ServiceLoctor stub
 frankpc.axis.services.OMSSecure.OMSSecureSoapBindingStub _stub = new 
frankpc.axis.services.OMSSecure.OMSSecureSoapBindingStub(portAddress, this);

Can not put traces in the SoapBindingStub constructor until after call 
to this(service), and it doe snot get pass that.

Any one have any thoughts?

One different thing that I did see is when I goto the service from a 
display page stand point.  The new custom deploy looks like this:


  OMSSecure

Hi there, this is an AXIS service!

Perhaps there will be a form for invoking the service here...

i.e. no form for the wsdl but you will get it if you append the ?wsdl

But using instant deploy I get

There is a Web Service here

Click to see the WSDL </axis/OMS.jws?wsdl>








Mime
View raw message