axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Griffin, Mark" <Mark.Grif...@pgnmail.com>
Subject RE: wsdl2java does not generate class-files for complexTypes
Date Mon, 21 Nov 2005 12:59:00 GMT
Christian,
Don't know if this will work for you, but I had a similar problem. Using
the -W option which turned off wrapped support worked for me. I was able
to then generate the classes.  Not completely sure why other than
something to do with the way axis is interpreting the wsdl.  I thought
my wsdl was docliteral wrapped but apparently axis thought otherwise.
At any rate it worked after the -W option.

markg

-----Original Message-----
From: Christian Schmitz [mailto:christian.schmitz@opitz-consulting.de] 
Sent: Monday, November 21, 2005 4:13 AM
To: axis-user@ws.apache.org
Subject: wsdl2java does not generate class-files for complexTypes


My WSDL defines the following complexTypes in the types-defintion:

  <xsd:complexType name="SearchResults">
    <xsd:sequence>
      <xsd:element name="ergebnisse" nillable="false" minOccurs="0" 
maxOccurs="unbounded" type="transporttypes:ResultLine"/>
    </xsd:sequence> 
  </xsd:complexType> 
  <xsd:complexType name="ResultLine">
    <xsd:sequence>
      <xsd:element name="ergebnisse" nillable="false" minOccurs="0" 
maxOccurs="unbounded" type="xsd:decimal" />
    </xsd:sequence> 
  </xsd:complexType>    

The complexType SearchResult should be returned by my service method.

  <wsdl:message name="searchResponse">
    <wsdl:part name="results" type="myNS:SearchResults"/>
  </wsdl:message>
...
    <soap:binding style="rpc" 
transport="http://schemas.xmlsoap.org/soap/http"/>
    <wsdl:operation name="search">
      <wsdl:input >
        <soap:body use="literal"/>
      </wsdl:input>
      <wsdl:output>
        <soap:body use="literal"/>
      </wsdl:output>
    </wsdl:operation>

wsdl2java does not generate the classes SearchResults an ResultLine. I 
expect that the tool should generate them. Instead of the expected, it 
generates a 2-dimensional Array as return type of my service method.

public java.math.BigDecimal[][] search(...) throws
java.rmi.RemoteException;

Is this the correct? Is it possible to configure wsdl2java to generate 
the classes?

regars,
Christian


Mime
View raw message