axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dovholuk, Clint" <Clint.Dovho...@GlobalCrossing.com>
Subject RE: Newbie question regarding adminclient
Date Mon, 21 Nov 2005 23:13:02 GMT
i would guess that the root of your problem is that activation.jar and
mail.jar are not in your classpath...
 
verify that your classpath has those two jars are in it.
 

________________________________

From: Randy Wigginton [mailto:randyw@quigo.com] 
Sent: Monday, November 21, 2005 6:11 PM
To: axis-user@ws.apache.org
Subject: Newbie question regarding adminclient



I apologize if this has been asked before, but I have been unable to
locate such a question.

 

I am executing this command:

java -cp %AXISCLASSPATH% org.apache.axis.client.AdminClient
deploy.wsdd

 

The error I get is:

17:52:00,398  WARN JavaUtils:1212 - Unable to find required classes
(javax.activation.DataHandler and javax.mail.interne

t.MimeMultipart). Attachment support is disabled.

Processing file deploy.wsdd

Exception: AxisFault

 faultCode:
{http://schemas.xmlsoap.org/soap/envelope/}Server.userException

 faultSubcode:

 faultString: java.lang.reflect.InvocationTargetException

 faultActor:

 faultNode:

 faultDetail:

        {http://xml.apache.org/axis/}hostname:nyc-randy

 

Unfortunately, I can't figure out how to get the real root of the
problem.  Here is my deploy.wsdd (I've cut everything I can out to still
show the problem).  I've also found one interesting adjunct, just below
the wsdd contents here:

 

<deployment

    xmlns="http://xml.apache.org/axis/wsdd/"

    xmlns:java="http://xml.apache.org/axis/wsdd/providers/java">

  <service name="ThirdPartyCampaignService" provider="java:RPC"
style="rpc" use="encoded">

      <parameter name="wsdlTargetNamespace"
value="urn:ThirdPartyCampaignService"/>

      <parameter name="wsdlServiceElement"
value="ThirdPartyCampaignServiceService"/>

      <parameter name="className"
value="com.quigo.ppcplus.service.thirdparty.campaign.ThirdPartyCampaignS
erviceSoapBindingSkeleton"/>

      <parameter name="allowedMethods" value="*"/>

      <parameter name="scope" value="Request"/>

      <typeMapping

        xmlns:ns="http://common.ppcplus.quigo.com"

        qname="ns:RTException"

        type="java:com.quigo.ppcplus.common.RTException"

        serializer="org.apache.axis.encoding.ser.BeanSerializerFactory"

 
deserializer="org.apache.axis.encoding.ser.BeanDeserializerFactory"

        encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"

      />

  </service>

</deployment>

 

If I change the name of the type - in any way - I get the <Admin>Done
processing</admin> message.  Even if I change the name of the class to
QRTexception, the package from .common. to .uncommon. ... literally
almost anything.  

 

Can anyone give me any kind of clue what is happening here?  If I set my
logging level to debug, I get a huge output... but I can't make heads or
tails of it.  Any hints?

 


Mime
View raw message