axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Developer Developer <devquesti...@gmail.com>
Subject Bad envelope tag: html
Date Wed, 05 Oct 2005 23:29:03 GMT
Ron, Thanks ! It did solve the problem.
  Now I am facing some other problem. ( Bad envelop tag problem).
 Do you know about this ?

C:\Tomcat 5.5\webapps\axis\Simple>java -cp %AXISCLASSPATH% org.apache.axis.c
t.AdminClient -lhttp://localhost:8080/axis/Simple Simple.wsdd
log4j:WARN No appenders could be found for logger (org.apache.axis.i18n.Proj
esourceBundle).
log4j:WARN Please initialize the log4j system properly.
Processing file Simple.wsdd
Exception: AxisFault
faultCode: {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
faultSubcode:
faultString: org.xml.sax.SAXException: Bad envelope tag: html
faultActor:
faultNode:
faultDetail:
{http://xml.apache.org/axis/}stackTrace:org.xml.sax.SAXException: Ba
velope tag: html
at org.apache.axis.message.EnvelopeBuilder.startElement(EnvelopeBuil
java:70)
at org.apache.axis.encoding.DeserializationContext.startElement(Dese
izationContext.java:1048)
at org.apache.xerces.parsers.AbstractSAXParser.startElement(Unknown
ce)
at org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanStartElement(
own Source)
at org.apache.xerces.impl.XMLNSDocumentScannerImpl$NSContentDispatch
canRootElementHook(Unknown Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentCon
Dispatcher.dispatch(Unknown Source)
at org.apache.xerces.impl.XMLDocumentFragmentScannerImpl.scanDocumen
known Source)
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source
at org.apache.xerces.parsers.XML11Configuration.parse(Unknown Source
at org.apache.xerces.parsers.XMLParser.parse(Unknown Source)
at org.apache.xerces.parsers.AbstractSAXParser.parse(Unknown Source)
at org.apache.xerces.jaxp.SAXParserImpl$JAXPSAXParser.parse(Unknown
ce)
at javax.xml.parsers.SAXParser.parse(Unknown Source)
at org.apache.axis.encoding.DeserializationContext.parse(Deserializa
Context.java:227)
at org.apache.axis.SOAPPart.getAsSOAPEnvelope(SOAPPart.java:696)
at org.apache.axis.Message.getSOAPEnvelope(Message.java:424)
at org.apache.axis.transport.http.HTTPSender.readFromSocket(HTTPSend
ava:796)
at org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:

at org.apache.axis.transport.http.HTTPSender.readFromSocket(HTTPSend
ava:727)
at org.apache.axis.transport.http.HTTPSender.invoke(HTTPSender.java:

at org.apache.axis.strategies.InvocationStrategy.visit(InvocationStr
y.java:32)
at org.apache.axis.SimpleChain.doVisiting(SimpleChain.java:118)
at org.apache.axis.SimpleChain.invoke(SimpleChain.java:83)
at org.apache.axis.client.AxisClient.invoke(AxisClient.java:165)
at org.apache.axis.client.Call.invokeEngine(Call.java:2765)
at org.apache.axis.client.Call.invoke(Call.java:2748)
at org.apache.axis.client.Call.invoke(Call.java:1784)
at org.apache.axis.client.AdminClient.process(AdminClient.java:439)
at org.apache.axis.client.AdminClient.process(AdminClient.java:404)
at org.apache.axis.client.AdminClient.process(AdminClient.java:410)
at org.apache.axis.client.AdminClient.process(AdminClient.java:320)
at org.apache.axis.client.AdminClient.main(AdminClient.java:463)

{http://xml.apache.org/axis/}hostname:IBM-900DE7D8334



 On 10/5/05, Ron Reynolds <Ron@ronreynolds.com> wrote:
>
> there's a whitespace (space, CR, tab) in your classpath that's being
> interpretted by the java exe as a delimiter
> between CP and the main class name. you might try quoting the whole CP
> ( java -classpath "%AXISCLASSPATH%" ...) tho all those extra quotes might
> throw it off,
> or use the "DOSified" version of your directory name ("TOMCAT~1.5")
> instead to avoid spaces.
> or move your jars into a simple \dev\lib directory and use a classpath
> like this:
>
> set AXIS_CP=.
> set AXIS_CP=%AXIS_CP%;/dev/lib/axis-1.2.1.jar
> set AXIS_CP=%AXIS_CP%;/dev/lib/jaxrpc-1.1.jar
> set AXIS_CP=%AXIS_CP%;/dev/lib/commons-logging-1.0.4.jar
> set AXIS_CP=%AXIS_CP%;/dev/lib/commons-discovery-0.2.jar
> set AXIS_CP=%AXIS_CP%;/dev/lib/wsdl4j-1.5.1.jar
> set AXIS_CP=%AXIS_CP%;/dev/lib/saaj-1.2.jar
> set AXIS_CP=%AXIS_CP%;/dev/lib/xmlsec-1.2.1.jar
> set AXIS_CP=%AXIS_CP%;/dev/lib/junit-3.8.1.jar
>
> (jar names may vary - i add version numbers to all jars if they're
> missing)
>
> hth.
> .................ron.
>
> > Has anybody seen this error before, if so what is the fix.
> > I am running Win XP.
> > Here is my output of AXISCLASSPATH- .
> > C:\Tomcat 5.5\webapps\axis>echo %AXISCLASSPATH%
> > "C:\Tomcat 5.5\webapps\axis\WEB-INF\lib"\axis.jar;"C:\Tomcat
> > 5.5\webapps\axis\WE
> > B-INF\lib"\commons-discovery.jar; "C:\Tomcat
> 5.5\webapps\axis\WEB-INF\lib
> > "\comm
> > ons-logging.jar;"C:\Tomcat 5.5\webapps\axis\WEB-INF\lib
> "\jaxrpc.jar;"C:\Tomcat
> > 5
> > .5\webapps\axis\WEB-INF\lib"\saaj.jar; "C:\Tomcat
> > 5.5\webapps\axis\WEB-INF\lib"
> > \log4j-1.2.8.jar;"C:\Tomcat 5.5\webapps\axis\WEB-INF\lib"\xml-apis.jar
> > ;"C:\Tomca
> > t 5.5\webapps\axis\WEB-INF\lib"\xercesImpl.jar
>
> > Here is the output of running the Admin client- not sure why it is not
> > working.
> > C:\Tomcat 5.5\webapps\axis>java -cp %AXISCLASSPATH%
> > org.apache.axis.client.Admin
> > Client -l ttp://localhost:8080/axis/Simple Simple.wsdd
> > Exception in thread "main" java.lang.NoClassDefFoundError: C:\Tomcat
> > 5/5\webapps
> > \axis\WEB-INF\lib\commons-logging/jar;C:\Tomcat
> > 5/5\webapps\axis\WEB-INF\lib\jax
> > rpc/jar;C:\Tomcat 5/5\webapps\axis\WEB-INF\lib\saaj/jar;
> >
>
>
>

Mime
View raw message