axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Bill Piepmeyer" <billp...@hotmail.com>
Subject Operation not specified in client request
Date Tue, 11 Oct 2005 23:07:31 GMT
Hi,
I am having trouble with my request in that in the SOAP env it does not put 
the operation.

This is what is created.

POST /opcxmlda/KEPware.KEPServerEx.V4 HTTP/1.0
Content-Type: text/xml; charset=utf-8
Accept: application/soap+xml, application/dime, multipart/related, text/*
User-Agent: Axis/1.2.1
Host: 127.0.0.1:9988
Cache-Control: no-cache
Pragma: no-cache
SOAPAction: "http://opcfoundation.org/webservices/XMLDA/1.0/Read"
Content-Length: 708


<?xml version="1.0" encoding="UTF-8"?>
   <soapenv:Envelope 
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" 
xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <soapenv:Body>
         <Options ReturnItemName="false" ClientRequestHandle="1" 
ReturnItemTime="true" ReturnErrorText="true" ReturnDiagnosticInfo="false" 
ReturnItemPath="false" 
xmlns="http://opcfoundation.org/webservices/XMLDA/1.0/"/>
         <ItemList MaxAge="0" 
xmlns="http://opcfoundation.org/webservices/XMLDA/1.0/">
            <Items MaxAge="0" ItemName="Channel1.Stencil.R800"/>
         </ItemList>
      </soapenv:Body>
   </soapenv:Envelope>


With the following change it works

<?xml version="1.0" encoding="UTF-8"?>
   <soapenv:Envelope 
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" 
xmlns:xsd="http://www.w3.org/2001/XMLSchema" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
      <soapenv:Body>
         <Read>
            <Options ReturnItemName="false" ClientRequestHandle="1" 
ReturnItemTime="true" ReturnErrorText="true" ReturnDiagnosticInfo="false" 
ReturnItemPath="false" 
xmlns="http://opcfoundation.org/webservices/XMLDA/1.0/"/>
            <ItemList MaxAge="0" 
xmlns="http://opcfoundation.org/webservices/XMLDA/1.0/">
               <Items MaxAge="0" ItemName="Channel1.Stencil.R800"/>
            </ItemList>
         </Read>
      </soapenv:Body>
   </soapenv:Envelope>


Note the addition of the <Read> and </Read>

I am not sure why these are not present and what needs to be done to include 
them. I have attached the WSDL file that was used to generate the java code.

TIA
--Bill


Mime
View raw message