axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ron Reynolds" <...@RonReynolds.com>
Subject Re: Bad envelope tag: html
Date Fri, 30 Sep 2005 05:32:48 GMT
i've seen this when i got redirected by an auth filter and the auth server sent an HTML form
(assuming the client was
a browser) which, of course, doesn't parse as soap very well.  it may be your server is trying
to return some form of
HTML error page or perhaps a generated directory listing (if the URL maps to a directory).
 relay through tcp mon or
get the client-side to dump the response to log to at least see what the client is getting.

hth.
.................ron.

> I have been working on using Apache Axis 1.2 to
> interact with a Web Service that is using nuSOAP.  I
> get the following error:
>
> - Exception in AddressingHandler
> AxisFault
>  faultCode:
> {http://schemas.xmlsoap.org/soap/envelope/}Server.userException
>  faultSubcode:
>  faultString: org.xml.sax.SAXException: Bad envelope
> tag:  html
>  faultActor:
>  faultNode:
>  faultDetail:
>
> {http://xml.apache.org/axis/}stackTrace:org.xml.sax.SAXException:
> Bad envelope tag:  html
>         at
> org.apache.axis.message.EnvelopeBuilder.startElement(EnvelopeBuilder.java:70)
>         at
> org.apache.axis.encoding.DeserializationContext.startElement(DeserializationContext.java:1048)
>         at
> org.apache.xerces.parsers.AbstractSAXParser.startElement(Unknown
> Source)
>
> What are the possible causes of this?
>
> Thanks for the help,
> JR
>
>
>
>
> __________________________________
> Yahoo! Mail - PC Magazine Editors' Choice 2005
> http://mail.yahoo.com
>



Mime
View raw message