axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Juan Cervera" <Juan.Cerv...@nomadsoft.com>
Subject Problems undeploying a service and with SOAPMonitor
Date Tue, 09 Aug 2005 09:29:35 GMT
Hi all,
 
Does anybody know why I get the following error when I try to undeploy
my services? I'm using Axis 1.2.1 final on WAS 5.0.2.12
 
Exception: AxisFault
 faultCode: {http://xml.apache.org/axis/}Client
 faultSubcode: 
 faultString: No such operation 'undeployment'
 faultActor: 
 faultNode: 
 faultDetail: 
        {http://xml.apache.org/axis/}hostname:<hostname>
 
I have to delete the service manually from the server-config.wsdd to
undeploy it. The undeploy.wsdd file is generated by Axis and its
contents seem fine:
<undeployment
    xmlns="http://xml.apache.org/axis/wsdd/">
 
  <!-- Services from DummyBalanceEnquiryService WSDL service -->
 
  <service name="DummyBalanceEnquiry"/>
</undeployment>

I have another problem too, this time with the SOAPMonitor, not the
applet one, which I cannot start for some other problems but the one
that you start by doing:
    java org.apache.axis.utils.SOAPMonitor
 
The first time it starts it works fine, then I select the service I want
to monitor and save the changes, it modifies the server-config.wsdd
file. After that, when I restart the monitor, the usernames and
passwords in the users.lst files won't work any more and will give me
"(401)Unauthorised", forcing me to maintain a copy of the
server-config.wsdd before I saved the changes from the SOAPMonitor, any
clues?
 
Thanks

Mime
View raw message