axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Davanum Srinivas <dava...@gmail.com>
Subject Re: Axis 1.1 to Axis 1.2.1 migration causes performance problems
Date Fri, 08 Jul 2005 02:09:45 GMT
YEP!!! that could be one. See
http://marc.theaimsgroup.com/?l=axis-user&m=110860275705924&w=2

-- dims

On 7/7/05, Naskovski, Martin <naskovsk@amazon.com> wrote:
> Srinivas - yes, I am actually in the process of setting up a test case-
> 
> However, I noticed one thing - On the Axis 1.2 I get the following xml parser:
> 
> Servlet version 2.4
> XML Parser com.sun.org.apache.xerces.internal.jaxp.SAXParserImpl
> XML ParserLocation an unknown location
> 
> On Axis 1.1 I get this:
> 
> Servlet version 2.4
> XML Parser org.apache.xerces.jaxp.SAXParserImpl
> XML ParserLocation an unknown location
> 
> Do you think this might be the cause of my 'slowness'?
> 
> I will set up a test case soon, if this (the xml parses) proves to be a moot issue.
> 
> Regards,
> -mn
> 
> -----Original Message-----
> From: Davanum Srinivas [mailto:davanum@gmail.com]
> Sent: Thursday, July 07, 2005 6:54 PM
> To: axis-user@ws.apache.org
> Subject: Re: Axis 1.1 to Axis 1.2.1 migration causes performance problems
> 
> that's weird!!. Could you please open a bug report with a test case for me to diagnose
and fix the problem?
> 
> thanks,
> dims
> 
> On 7/7/05, Naskovski, Martin <naskovsk@amazon.com> wrote:
> > Hi - I just migrated my Axis 1.1 based app to Axis 1.2.1 - and I have noticed quite
a serious performance decrease in the 1.2.1 version. The exact same application, nothing was
changed on either side, client or server, other than the Axis layer, and when I am posting
data to my Tomcat 5.5.9/JDK 1.5.0_03 based SOAP service - stuff just moves on much slower
than on Axis 1.1.  Thus I reverted back to Axis 1.1. and now the performance is up to snuff-
but I'd like to know if there is anything that was done since 1.2.1 was released to address
these performance issues? Thanks!
> >
> > Regards,
> > -mn
> > P.s. or is it possible that there is something other than Axis causing the slowdown?
I just want to make sure if I'm the only one :), so I can proceed correctly.
> >
> 
> 
> --
> Davanum Srinivas -http://blogs.cocoondev.org/dims/
> 


-- 
Davanum Srinivas -http://blogs.cocoondev.org/dims/

Mime
View raw message