axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jack_Emmeri...@eFunds.Com
Subject NoClassDefFoundError when creating service stub
Date Thu, 23 Jun 2005 12:57:34 GMT
I'm an Axis newby, so please pardon any obvious dumb mistakes I'm trying 
to find.

I'm trying to follow the example in the Axis User Guide for implementing 
the client side bindings.  I've created all the generated Java code from 
the service WSDL (using the Lavadora Eclipse plugin, but the code looks 
correct).  I'll generalize the names of the four interface class files as 
ServiceInterface, ServiceLocator, PortInterface, and PortStub.  This is 
all in one test project, so the client and server components are in 
different packages.

Using the User Guide example, I'm trying to execute the following code:

        ServiceInterface myService = new ServiceLocator();
        PortInterface MyPort = myService.getServerName();

The first line works fine.  The second line executes the portion of 
myService.getServerName() which creates the URL and than calls 
myService.getServerName(URL)  However, the line of code which essentially 
says:

        clientPackage.PortStub _stub = new 
clientPackag.PortStub(portAddress, this);

This line of code generates a  java.lang.NoClassDefFoundError exception, 
and won't tell me what the class is that is not found, and blows up in 
code that I don't have the source for

If I create my own Call object and use it directly, the service works just 
fine, so the problem is not the client, the service, Tomcat, Axis, or any 
other external items. 
I seem to have some sort of class definition (classpath?) error in 
creating the PortStub.  Anybody have any idea what this might be?

JFE.

Mime
View raw message