axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Alberto De Stasi" <progetto_z...@hotmail.com>
Subject Web Service Axis without response to client
Date Tue, 07 Jun 2005 11:45:40 GMT
Hi all,

but I always have this problem too with axis web service.

I want a service that into TCP Monitor it's show only request (client to 
service) without response (service to client). I want to use an One Way 
method with Axis.

This example (request and response) works with .Net (client VB .Net and web 
server .Net).
My request is:

POST /PortaApplicativaDemo/Porta01.asmx HTTP/1.1
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; MS Web Services Client 
Protocol 1.1.4322.573) Content-Type: text/xml;
charset=utf-8
SOAPAction: "WebMethod"
Content-Length: 987
Expect: 100-continue
Connection: Keep-Alive
Host: 192.168.11.195:8081

<?xml version="1.0" encoding="utf-8"?>
   <soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" 
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" 
xmlns:xsd="http://www.w3.org/2001/XMLSchema">
      <soap:Header>
         … my header
      </soap:Header>
      <soap:Body>
         … my body
      </soap:Body>
   </soap:Envelope>

and my response is:

HTTP/1.1 100 Continue
Server: Microsoft-IIS/5.0
Date: Tue, 07 Jun 2005 09:11:21 GMT
X-Powered-By: ASP.NET

HTTP/1.1 202 Accepted
Server: Microsoft-IIS/5.0
Date: Tue, 07 Jun 2005 09:11:23 GMT
X-Powered-By: ASP.NET X-AspNet-Version: 1.1.4322
Cache-Control: private
Content-Length: 0

Notice that the response of .Net Service use a HTTP 202 status code and it 
does not answer to client. I want this.

Now, I don't know how do you do?

I can to think that the problem is:
  1. my web service method
  2. or create a status code HTTP 202 accepted by service

How can I resolve this problem?

Thanks Pasquy

_________________________________________________________________
Comunica in tempo reale http://messenger.msn.com/beta


Mime
View raw message