axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Duarte Marques Moreira" <Duarte.More...@altitude.com>
Subject "soapenv:encodingStyle": duplicate attribute
Date Tue, 21 Jun 2005 11:23:41 GMT
Hello,
 
I have an application that is using axis 1.2.1 to access .net remoting
objects. 
Sometimes, when two threads are concurrently making calls, the axis
engine duplicates
the "soapenv:encodingStyle" attribute, causing a .net exception at
server side:
 
 
2005-06-21 12:00:21,171 agent01 DEBUG Start element
[http://schemas.xmlsoap.org/soap/envelope/]:Envelope
2005-06-21 12:00:21,171 agent02 DEBUG Start element
[http://schemas.xmlsoap.org/soap/envelope/]:Envelope
2005-06-21 12:00:21,171 agent02 DEBUG
org.apache.axis.i18n.resource::handleGetObject(startElem00)
2005-06-21 12:00:21,171 agent01 DEBUG
org.apache.axis.i18n.resource::handleGetObject(startElem00)
2005-06-21 12:00:21,171 agent02 DEBUG Start element
[http://schemas.xmlsoap.org/soap/envelope/]:Body
2005-06-21 12:00:21,171 agent01 DEBUG Start element
[http://schemas.xmlsoap.org/soap/envelope/]:Body
2005-06-21 12:00:21,171 agent02 DEBUG NSPush (32)
2005-06-21 12:00:21,171 agent01 DEBUG NSPush (32)
2005-06-21 12:00:21,171 agent01 DEBUG
org.apache.axis.i18n.resource::handleGetObject(startElem00)
2005-06-21 12:00:21,171 agent02 DEBUG
org.apache.axis.i18n.resource::handleGetObject(startElem00)
2005-06-21 12:00:21,171 agent01 DEBUG Start element
[http://schemas.microsoft.com/clr/nsassem/Altitude.IntegrationServer.IAp
i.IIntegrationServer/Altitude.IntegrationServer.IApi]:GetToString
2005-06-21 12:00:21,171 agent02 DEBUG Start element
[http://schemas.microsoft.com/clr/nsassem/Altitude.IntegrationServer.IAp
i.IIntegrationServer/Altitude.IntegrationServer.IApi]:GetToString
2005-06-21 12:00:21,171 agent01 DEBUG
org.apache.axis.i18n.resource::handleGetObject(register00)
2005-06-21 12:00:21,171 agent02 DEBUG
org.apache.axis.i18n.resource::handleGetObject(register00)
2005-06-21 12:00:21,171 agent01 DEBUG register 'ns1' -
'http://schemas.microsoft.com/clr/nsassem/Altitude.IntegrationServer.IAp
i.IIntegrationServer/Altitude.IntegrationServer.IApi'
2005-06-21 12:00:21,171 agent02 DEBUG register 'ns1' -
'http://schemas.microsoft.com/clr/nsassem/Altitude.IntegrationServer.IAp
i.IIntegrationServer/Altitude.IntegrationServer.IApi'
2005-06-21 12:00:21,171 agent01 DEBUG NSPush (32)
2005-06-21 12:00:21,171 agent02 DEBUG NSPush (32)
2005-06-21 12:00:21,171 agent01 DEBUG NSPush (32)
2005-06-21 12:00:21,171 agent02 DEBUG NSPush (32)
2005-06-21 12:00:21,171 agent01 DEBUG
org.apache.axis.i18n.resource::handleGetObject(endElem00)
2005-06-21 12:00:21,171 agent02 DEBUG
org.apache.axis.i18n.resource::handleGetObject(endElem00)
2005-06-21 12:00:21,187 agent01 DEBUG End element ns1:GetToString
2005-06-21 12:00:21,187 agent02 DEBUG End element ns1:GetToString
2005-06-21 12:00:21,187 agent01 DEBUG NSPop (32)
2005-06-21 12:00:21,187 agent02 DEBUG NSPop (32)
2005-06-21 12:00:21,187 agent01 DEBUG
org.apache.axis.i18n.resource::handleGetObject(endElem00)
2005-06-21 12:00:21,187 agent02 DEBUG
org.apache.axis.i18n.resource::handleGetObject(endElem00)
2005-06-21 12:00:21,187 agent01 DEBUG End element soapenv:Body
2005-06-21 12:00:21,187 agent02 DEBUG End element soapenv:Body
2005-06-21 12:00:21,187 agent01 DEBUG NSPop (32)
2005-06-21 12:00:21,187 agent02 DEBUG NSPop (32)
2005-06-21 12:00:21,187 agent01 DEBUG
org.apache.axis.i18n.resource::handleGetObject(endElem00)
2005-06-21 12:00:21,187 agent02 DEBUG
org.apache.axis.i18n.resource::handleGetObject(endElem00)
2005-06-21 12:00:21,187 agent01 DEBUG End element soapenv:Envelope
2005-06-21 12:00:21,187 agent02 DEBUG End element soapenv:Envelope
2005-06-21 12:00:21,187 agent01 DEBUG
org.apache.axis.i18n.resource::handleGetObject(empty00)
2005-06-21 12:00:21,187 agent02 DEBUG
org.apache.axis.i18n.resource::handleGetObject(empty00)
2005-06-21 12:00:21,187 agent01 DEBUG NSPop (empty)
2005-06-21 12:00:21,187 agent02 DEBUG NSPop (empty)
2005-06-21 12:00:21,187 agent01 DEBUG <?xml version="1.0"
encoding="UTF-8"?><soapenv:Envelope
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><soapenv:Body><ns1
:GetToString
soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
xmlns:ns1="http://schemas.microsoft.com/clr/nsassem/Altitude.Integration
Server.IApi.IIntegrationServer/Altitude.IntegrationServer.IApi"/></soape
nv:Body></soapenv:Envelope>
2005-06-21 12:00:21,187 agent02 DEBUG <?xml version="1.0"
encoding="UTF-8"?><soapenv:Envelope
xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance"><soapenv:Body><ns1
:GetToString
soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
xmlns:ns1="http://schemas.microsoft.com/clr/nsassem/Altitude.Integration
Server.IApi.IIntegrationServer/Altitude.IntegrationServer.IApi"/></soape
nv:Body></soapenv:Envelope>
2005-06-21 12:00:21,187 agent01 DEBUG Enter: AxisClient::invoke
2005-06-21 12:00:21,187 agent02 DEBUG Enter: AxisClient::invoke
 
 
With only one thread everything works ok. This problem didn't occur with
axis 1.0. 
Has anybody experienced such a problem? Is there a workaround?
 
Thanks in advance,
Duarte
 
.....................................................
Duarte Marques Moreira
R&D
Altitude Software (formerly Easyphone)
 
 <mailto:duarte.moreira@altitude.com> mailto:duarte.moreira@altitude.com
 <http://www.altitude.com> http://www.altitude.com 
 
+ 351 214 12 98 00 main
+ 351 214 12 98 90 fax
 
Av. dos Combatentes 43, 1
1600-042 Lisbon, PORTUGAL
 

Mime
View raw message