axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Miller, Janet" <Mille...@pbworld.com>
Subject RE: Problem setting up Axis
Date Wed, 29 Jun 2005 17:58:34 GMT
I meant to say Tomcat/common/lib.

Jan

-----Original Message-----
From: Miller, Janet 
Sent: Wednesday, June 29, 2005 1:56 PM
To: 'axis-user@ws.apache.org'
Subject: RE: Problem setting up Axis


That didn't work, but putting tools.jar under Tomcat/lib and restarting Tomcat did work!!

Jan

-----Original Message-----
From: Gary Zhu [mailto:gzhu@timeicr.com] 
Sent: Wednesday, June 29, 2005 12:05 PM
To: axis-user@ws.apache.org
Subject: RE: Problem setting up Axis


You can copy the tools.jar and put it under your Axis context. You need to restart Tomcat
for it to work.

Gary 

-----Original Message-----
From: Miller, Janet [mailto:MillerJa@pbworld.com] 
Sent: June 29, 2005 11:21 AM
To: axis-user@ws.apache.org
Subject: RE: Problem setting up Axis

I've done all of this.  My Axis happy page displays correctly, but when I try to access a
sample JWS web service that comes with Axis as follows:

http://localhost:8080/axis/EchoHeaders.jws?method=list 

I get the following error:

  <faultcode>soapenv:Server.userException</faultcode>
  <faultstring>java.lang.RuntimeException: No compiler found in your classpath! (you
may need to add 'tools.jar')</faultstring> 

How does Axis know where the Java compiler is?  I thought it used CLASSPATH and AXISCLASSPATH
which I think I have set up properly since I got wsdl2Java to work.  Do I need to put tools.jar
somewhere?

I tried adding tools.jar to the tomcat\common\lib directory, but that didn't work either.

I'm using Tomcat 5.5.9, Java 1.5.0.03, and Axis 1.2.1.

Does anyone know why I'm having this problem?

Jan

-----Original Message-----
From: Ferruh Zamangoer [mailto:ferruh.zamangoer@gmx.de]
Sent: Tuesday, June 28, 2005 3:16 AM
To: axis-user@ws.apache.org
Subject: AW: Problem setting up Axis


The best way to set up axis is to copy axis-1_2/webapps/axis into your tomcat ....\Apache
Group\Tomcat 4.1\webapps folders.




-----Urspr√ľngliche Nachricht-----
Von: Ferruh Zamangoer [mailto:ferruh.zamangoer@gmx.de] 
Gesendet: Dienstag, 28. Juni 2005 08:52
An: axis-user@ws.apache.org
Betreff: AW: Problem setting up Axis

Hi Janet,

if you have downloaded the axis-1_2.zip binaries you can extract this file. After you have
extracted you have a folder structure like:

- axis-1_2
   - docs
   - lib
   - samples
   - webapps
   - xmls

Normally the wsdl4j.jar must be in lib directory, otherwise you can look at axis-1_2\webapps\axis\WEB-INF\lib.
The wsdl4j.jar is used in AXIS to generate Java code from WSDL and to generate WSDL from Java.

Hope it helps.

Regards
Ferruh




-----Urspr√ľngliche Nachricht-----
Von: Miller, Janet [mailto:MillerJa@pbworld.com] 
Gesendet: Dienstag, 28. Juni 2005 01:05
An: axis-user@ws.apache.org
Betreff: RE: Problem setting up Axis

I am also missing a file called wsdl4j.jar which the Axis documentation says is supposed to
be in my CLASSPATH and AXISCLASSPATH.  I've installed everything and don't have this file
on my machine.  Where does this file come from?  Could someone check to see if this file exists
on your machine?  It is supposed to be in the \webapps\axis\WEB-INF\lib directory.

I can't get Axis to work.  The happyAxis page is displaying properly though.

Thanks,

Jan


Mime
View raw message