axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Manuel Nicolas Ortuño <manuel.nicol...@carm.es>
Subject AxisFault: Did not understand "MustUnderstand" header(s)
Date Thu, 26 May 2005 13:06:35 GMT
I have a client of web service that use axis api. When I call the service I
get the exception 

 

AxisFault

 faultCode: {http://schemas.xmlsoap.org/soap/envelope/}MustUnderstand

 faultSubcode: 

 faultString: Did not understand &quot;MustUnderstand&quot; header(s):

 faultActor: 

 faultNode: 

 faultDetail: 

      {http://xml.apache.org/axis/}stackTrace:

      at
org.apache.axis.handlers.soap.MustUnderstandChecker.invoke(MustUnderstandChe
cker.java:96)

      at org.apache.axis.client.AxisClient.invoke(AxisClient.java:206)

      at org.apache.axis.client.Call.invokeEngine(Call.java:2765)

      at org.apache.axis.client.Call.invoke(Call.java:2748)

      at org.apache.axis.client.Call.invoke(Call.java:1902)

      at es.carm.ctyc.wc.CSigepal.m1.main(m1.java:66)

 

Axis 1.2

j2sdk1.4.2_08

 

…

Service service = new Service();

Call call = (org.apache.axis.client.Call) service.createCall();

…

call.invoke…

 

I’d see xml that the service web return and the problem is <sap:Main
xmlns:sap="…" versionMajor="3" versionMinor="0" SOAP:mustUnderstand="1">

With axis 1.1 not problem but with 1.2 throw exception

Please help, how I solve this?

Thx


Mime
View raw message