axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Mike Barton <mbar...@allesta.com>
Subject Re: /services/ intermittent display
Date Wed, 25 May 2005 22:15:47 GMT
Michael,

Try using WSABI, which allows you manage Axis via a simple web based 
GUI.  This should get you going really fast.  WSABI is available at:

Download: http://sourceforge.net/projects/wsabi4axis
Information: http://www.allesta.com
Live Demo: http://demo.wsabi.org


--Mike


Michael Oliver wrote:
> I have built and deployed a web service as part of an existing Web 
> Application.
> 
>  
> 
> I deployed the web service using the AdminClient and deploy.wsdd
> 
>  
> 
> The Web Service is accessible and 
> /services/AlariusAssignmentsServicces?wsdl works
> 
> And the service methods are accessible and also work.
> 
>  
> 
> What puzzles me is that before I did the AdminClient deploy of the 
> deploy.wsdd I got a page at /services/ that said
> 
>  
> 
> “No service is available at this URL”
> 
>  
> 
> After I did the AdminClient deploy.wsdd I saw the attached 
> server-config.wsdd and /services/ alone gave a display that showed the 
> services and links to get the wsdl
> 
>  
> 
> But after restarting Tomcat, the services still work, but the page at 
> /services/ has reverted to “No service is available at this URL”
> 
>  
> 
> Log4j debug org.apache.axis shows that AxisServlet is running and 
> appears to be processing through the server-config.wsdd but the display 
> doesn’t change.
> 
>  
> 
> I would like to get that page display running again for demo purposes 
> and while it doesn’t seem to affect the processing of the web services, 
> it is a comfort thing that if the display shows its there, I may be able 
> to skip actually exercising it depending on the audience for the demo.
> 
>  
> 
> Michael Oliver
> 
> CTO
> 
> Alarius Systems LLC
> 
> 6800 E. Lake Mead Blvd, #1096
> 
> Las Vegas, NV 89156
> 
> Phone:(702)643-7425
> 
> Fax:(702)974-0341
> 
> *Note new email changed from oliverm@matrix-media.com
> 
>  
> 


Mime
View raw message