axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vincent Jong <vincent.j...@gmail.com>
Subject SOAP Monitor not able to communicate with the server and how to undeploy the SOAP Monitor for redeployment
Date Sat, 23 Apr 2005 22:05:02 GMT
I've successfully got Axis 1.2rc2 going on my test workstation and
decided to get everything set up on one of our content servers.  What
i did was install Java 1.4.2_08 on the content server and then
proceded to scp my tomcat and axis install directories to the content
servers.  After adding in all the environment variables and paths,
everything was good to go.  Initial tests of the sample services were
good, but when i went to start the SOAP Monitor, the applet loaded up
fine, but it couldn't connect to the server.  I tried changing the
port variable in the source code from 0 to a port that we have open
and redeploying the SOAP Monitor, but it didn't work.  I'm not very
versed in ports and things like that (as a matter of fact, I've just
started using axis and java) and i'm wondering, what is the
significance of this service and port 0?  Why is the SOAP Monitor
unable to connect to the server and which server is it trying to
connect to?  I thought maybe it was because you need to undeploy the
service first before deploying it again, but i didn't find anything
about undeploying the SOAP Monitor.  I tried making my own
undeploy.wsdd with the contents of:

 <undeployment xmlns="http://xml.apache.org/axis/wsdd/"
    xmlns:java="http://xml.apache.org/axis/wsdd/providers/java">
        <service name="SOAPMonitorService"/>
</undeployment>

in order to undeploy the service, but after starting and restarting
tomcat, the applet was still being loaded even though i hadn't
redeployed the service yet.

Any suggestions on helping me get the SOAP Monitor working would be
greatly appreciated.  If there's more information that you need,
please let me know.

Thanks for you consideration in this matter.

Vincent J.

Mime
View raw message