axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Jess Balint <jbal...@gmail.com>
Subject Address already in use error
Date Sat, 09 Apr 2005 16:29:30 GMT
Hi, I am developing a simple client/server app using Axis. I am
performing some loading testing with the client. In my development
area, the client and the server are running on the same computer. The
server is running in Resin v3. The client is using Axis 1.2 RC 2/3
(tried both). After many connections, I am getting an error:

java.net.BindException: Address already in use: connect

Both client and server are running on Windows for testing. The first
time I run the test and it fails, there are 1989 connections in
TIME_WAIT state. Sometimes, I can run it again and it works fine, but
there are still 1986-1989 TIME_WAIT connections during and after the
test.

The client(s) are using the Spring support for JAX-RPC to make the
calls. What I need to know is if this is to be expected and whether or
not there is a way to fix it. I haven't yet looked into checking the
OS network parameters.

I've attached a copy of the exception if it's of any interest:
http://www.improvedideas.com/files/axis-exception.txt

TIA.
Jess

Mime
View raw message