axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From John Green <jggree...@yahoo.com>
Subject Re: Axis 1.1 Array Problems
Date Thu, 28 Apr 2005 16:55:57 GMT
Anne,

Sorry to hit you directly, but I wanted to thank you
so very much for your response, I got a simple case to
work.  I changed the type to rpc/encoded and got an
array of strings and a class wrapping an array of
strings back. It is amazing that it was such a simple
fix.  

Of course I had to push the envelope and add an array
of a complex type.  Well once I did that, now I get a
problem with a missing serializer.  I modified the
mapping and deployment files, but not sure why it
cannot find the serializer.  I have attached the WSDL,
Bean, Mapping, and Deployment files.  I want to put
together a lessons learned post because it seems like
there is tons of hunting and pecking going on to try
and get this working.

Any insight into this you could provide would be quite
helpful.

Once again, thank you very much for your response and
look forward to seeing more posts from you.

Thanks,

John Green


 


--- Anne Thomas Manes <atmanes@gmail.com> wrote:
> Don't try to use rpc/literal with Axis 1.1.
> You have three choices:
> - use rpc/encoded
> - use document/literal (I suggest "wrapped" style)
> - upgrade to Axis 1.2
> 
> Anne
> 
> On 4/27/05, John Green <jggreenjr@yahoo.com> wrote:
> > All,
> > 
> > I am seeing lots of posts about problems with
> arrays.
> > Not sure what the solution is, the problem I am
> seeing
> > is that an array is being populated with many
> elements
> > on the server-side, but on the client I am only
> > getting the last element in the array.  I have
> tried
> > several things from changing the style and use in
> the
> > ant task, to wrapping the array in a class.  Here
> is
> > what is generated in the WDSL for the class that
> > contains the array.
> > <complexType name="ProviderArray">
> >     <sequence>
> >      <element name="providerArray" nillable="true"
> > type="impl:ArrayOf_tns1_Provider"/>
> >     </sequence>
> > </complexType>
> > <complexType name="GetProvidersResponse">
> >     <complexContent>
> >      <extension base="tns1:ResponseMessage">
> >       <sequence>
> >        <element name="providers" nillable="true"
> > type="tns1:ProviderArray"/>
> >       </sequence>
> >     </extension>
> > </complexContent>
> > </complexType>
> > <complexType name="ArrayOf_tns1_Provider">
> >     <complexContent>
> >      <restriction base="soapenc:Array">
> >       <attribute ref="soapenc:arrayType"
> > wsdl:arrayType="tns1:Provider[]"/>
> >      </restriction>
> >     </complexContent>
> > </complexType>
> > 
> > Can anyone give me some new suggestions to try? 
> Is
> > this a bug with the ant task?  Here is the ant
> task I
> > have setup:
> > <axis-java2wsdl
> >
>
classname="net.ussouth.incomm.postpay.webService.WebServiceFacadeEndpoint"
> >
>
namespace="http://net.ussouth.incomm.postpay.webService/"
> >
>
location="http://localhost:8080/ws4ee/services/WebServiceFacadeService"
> >             serviceElementName="WebServiceFacade"
> >            
> servicePortName="WebServiceFacadeEndpoint"
> >             style="rpc"
> >             use="literal"
> > output="${rsrc.home}/wsdl/WebServiceFacade.wsdl">
> > <classpath refid="classpath" />
> > </axis-java2wsdl>
> > 
> > Thanks,
> > 
> > John Green
> > 
> >
> 
Mime
View raw message