axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Dino Chiesa" <din...@microsoft.com>
Subject FW: replacing default namespace prefixes
Date Wed, 09 Mar 2005 15:53:10 GMT
Moving this back to axis-user. . .  

-----Original Message-----
From: Andy Dolbey [mailto:andy.dolbey@gmail.com] 
Sent: Wednesday, March 09, 2005 10:26 AM
To: dexterwong@iwon.com
Cc: Dino Chiesa
Subject: Re: replacing default namespace prefixes

Sure, I've attached it here.  It was a wsdl automatically generated by
the Allegro Common Lisp SOAP engine/server.  It led to a couple problems
that needed to be resolved first, like setting the client engine's
do_multirefs property to Boolean.false.  But the complex element with
string arrays hasn't been a problem.  I agree with your point totally,
Dino, that the prefix used is arbitrary and semantically unimportant.
But the Lisp server appears to be complaining about it.

The odd thing is that I made a pseudo version of the Lisp service, again
in Lisp and with the exact same SOAP message structures, and everything
worked fine.  This time I had control over the server so I could turn on
the XML traces.  I could see the `ns1:' prefix showing up in the
message, but the transactions went through fine.  The wsdl I used was
automatically generated the same way by Allegro Common Lisp, and I used
the same Axis wsdl2java libraries.  I truly don't understand why one
works but the other doesn't.

It seems to me that these are the key places where differences can
arise:

 1) Lisp SOAP element defs
 2) Lisp SOAP server def
 3) Lisp name-space specs
 4) Lisp generation of a wsdl
 5) Axis generation of client classes from a wsdl
 6) Java client driver class that uses the pieces in the previous step

My pseudo version of the service is close to identical to the real one,
and yet it works with no problems even though real one does not. 
Very frustrating.  I'm attaching the wsdl for my pseudo version as well.
If you see a likely place where this difference could be coming from,
please let me know!  I'm leaning towards #3, the name-space specs, being
the problem, but I haven't discovered how yet.

Thanks for any thoughts or ideas.

The two files I'm attaching are the following.

wsdl for service with problem:

  DtronRPC20050307-compbio.wsdl

wsdl for pseudo version that works:

  DtronAxisRPC.wsdl


Andy




On Wed,  9 Mar 2005 08:32:06 -0500 (EST), dexterwong@iwon.com
<dexterwong@iwon.com> wrote:
> 
> Just curious is there a way we can see the wsdl.
> 
> 
>  --- On Tue 03/08, Andy Dolbey < andy.dolbey@gmail.com > wrote:
> 
> From: Andy Dolbey [mailto: andy.dolbey@gmail.com]
> 
> To: axis-user@ws.apache.org
> 
> Date: Tue, 8 Mar 2005 17:53:01 -0700
> 
> Subject: replacing default namespace prefixes
> 
> Hello axis-users,<br><br>I have a question that I've seen come up in 
> this group several times,<br>but so far I haven't seen an answer.  So 
> I'll try throwing out the<br>question again.<br><br>I have a wsdl for

> a service that I have used Axis-1.2 to generate<br>client classes for.

> This went fine.  But now when I make requests,<br>Axis is using the 
> namespace prefix "ns1" as a default.  But the SOAP<br>server (which is

> a Common Lisp server) really wants the prefix to be<br>"tns".  And in 
> fairness to the server, this is the prefix specified in<br>the wsdl.  
> With a ns1 prefix, I now get error messages for 
> all<br>requests.<br><br>Is there a way to set the default prefix Axis

> uses?  I tried grep'ing<br>all of the source for "ns1", but didn't 
> find anything.<br><br>This problem is draining a lot my time.  If 
> anyone has any ideas or<br>suggestions, please let me 
> know!<br><br>Thanks.<br><br>Andy<br>
> 
> _______________________________________________
> 
>

Mime
View raw message