axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Assaf Mizrachi" <as...@pointer.co.il>
Subject Problem with basic deployment
Date Sun, 06 Feb 2005 12:41:46 GMT
Hi All,
Sorry, but I just tried everything and I'm still unable to deploy the
simplest web service and I keep getting the same error.
The following is what I get when I try to deploy the stock example from
/axis/samples/stock:
 
I try:
"C:\jakarta-tomcat-4.1.24\webapps\axis\WEB-INF\classes\samples\stock>jav
a -cp %AXISCLASSPATH% org.apache.axis.client.AdminClient
-lhttp://localhost:8080/axis/services/AdminService deploy.wsdd"
 
I get:
"Exception in thread "main" java.lang.NoClassDefFoundError:
C:\axis-1_1\lib\commons-discovery/jar;"
 
This is what I get also when trying to deploy /axis/samples/sample2 and
the SOAPMonitorApplet's wsdd file (deploy-monitor.wsdd).
Installation tests went fine till now except from one optional component
missing (xmlsec.jar) in the happyaxis.jsp check.
Version of Axis is 1.1 and of Tomcat is 4.1.24.
I have double checked myself and there are no typos in this message, so
don't bother looking for them (or asking).
 
Any suggestions?
 
Thanks in advance,
Your help will be highly appreciated,
 
Assaf.
 
Assaf Mizrachi,
SW Engineer,
Pointer SW Systems, Ltd. <http://www.pointer.co.il> 
Tel: 04-9597299 ext.33
Cell: 052-2888729
 

Mime
View raw message