axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Davanum Srinivas <dava...@gmail.com>
Subject Re: [axis-user-ja digest] xml error when boot up Tomcat
Date Wed, 19 Jan 2005 14:42:09 GMT
Toshi,

You need to figure this one out :) or ask ias/jongjin for help :) :)
As always, start with a JIRA bug report.

-- dims

PS: i have no idea how to start fixing this one.


On Tue, 18 Jan 2005 21:36:27 -0800 (PST), Toshiyuki Kimura
<toshi@apache.org> wrote:
> Hi folks,
> 
>   This is a digest report from the Japanese Axis User community.
> 
> The followings are the scenario of the UTFDataFormatException:
> 
>   1. He installed TOMCAT to a folder which includes non-ASCII
>      charactors.
>   2. The folder name was used in axis/WEB-INF/server-config.wsdd
>      to specify "attachments.Directory".
>   3. The file indicated its encoding type as "UTF-8" in the top
>      of the file - '<?xml version="1.0" encoding="UTF-8"?>'.
>   4. But, the _real_ encoding of the file was not UTF-8.
> 
>    After (re)saving the file as UTF-8 by using notepad, the boot
> error (java.io.UTFDataFormatException) has solved.
> 
>    But, after that, he still has faced a number of class loading
> problems. So, he reinstalled TOMCAT and Axis to an ASCII-based
> folder. Finally, he could work with Axis.
> 
> Thanks,
> Toshi <toshi@apache.org>
> 
> On Thu, 13 Jan 2005, Toshiyuki Kimura wrote:
> 
> > This thread has moved to axis-user-ja@ws.a.o.
> > I'll be back with a summary when it's solved.
> >
> > Thanks,
> > Toshi <toshi@apache.org>
> >
> > On Thu, 13 Jan 2005, Toshiyuki Kimura wrote:
> >
> >> Chu,
> >>
> >> Can you post 'server-config.wsdd' in webapps\axis\WEB-INF ?
> >> I guess that the file includes something invalid.
> >>
> >> OTOH, it may be as well to put your system detail (OS, JVM etc)
> >> if you want to have more feedbacks.
> >>
> >> Thanks,
> >> Toshi <toshi@apache.org>
> >>
> >> On Thu, 13 Jan 2005, chu wrote:
> >>
> >>> Hi,
> >>>
> >>> I am new on Axis & Tocmcat. I just followed the Axis
> >>> Installation Instructions to install Axis1.2RC2 with Tomcat 5.5.
> >>> And I had the following errors when I boot up Tomcat
> >>>
> >>> ....
> >>> 2005/01/13 16:17:31 org.apache.catalina.core.StandardEngine start
> >>> INFO: Starting Servlet Engine: Apache Tomcat/5.5.4
> >>> 2005/01/13 16:17:31 org.apache.catalina.core.StandardHost start
> >>> INFO: XML検証は無効です <-- XML invalid verification
> >>> - Exception:
> >>> org.apache.axis.ConfigurationException: java.io.UTFDataFormatException:
> >>> Invalid byte 1 of 1-byte UTF-8 sequence.
> >>> java.io.UTFDataFormatException: Invalid byte 1 of 1-byte UTF-8 sequence.
> >>>        at org.apache.xerces.impl.io.UTF8Reader.invalidByte(Unknown
> >>> Source)
> >>>        at org.apache.xerces.impl.io.UTF8Reader.read(Unknown Source)
> >>>        at org.apache.xerces.impl.XMLEntityScanner.load(Unknown Source)
> >>>        at org.apache.xerces.impl.XMLEntityScanner.scanLiteral(Unknown
> >>> Source)
> >>>        at org.apache.xerces.impl.XMLScanner.scanAttributeValue(Unknown
> >>> Source)
> >>>        at
> >>> org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanAttribute(Unknown
> >>> Source)
> >>>        at
> >>> org.apache.xerces.impl.XMLNSDocumentScannerImpl.scanStartElement(Unkn
> >>> own Source)
> >>>        at
> >>> org.apache.xerces.impl.XMLDocumentFragmentScannerImpl$FragmentContent
> >>> ....
> >>>
> >>> Any helps are appreciated.
> >>>
> >>> Thanks & Regards
> >>>
> >>
> >
> 


-- 
Davanum Srinivas - http://webservices.apache.org/~dims/

Mime
View raw message