axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Davanum Srinivas <dava...@gmail.com>
Subject Re: Axis and Java 1.5
Date Fri, 10 Dec 2004 20:45:09 GMT
or replace all references of org.apache.axis.enum.* to
org.apache.axis.constants.*

-- dims


On Fri, 10 Dec 2004 12:34:57 -0700, ANDREW MICONE <AMICONE@deq.idaho.gov> wrote:
> Re-gen your java classes from the WSDL (making sure to move your BindingImpl out of the
tree so that can be regenerated as well). I got this to work. You might want to consider just
tooling back to JDK 1.42. That's what I did after I figured out that all JDK 1.5 was buying
me was a little better error message processing on compile. Most everything else I use could
be added to the 1.4 environment by adding the right jars to the CLASSPATH. -- Andy
> 
> >>> footh@yahoo.com 12/10/04 12:06PM >>>
> 
> 
> Thanks for the reply.
> 
> After I posted my message yesterday, I did go ahead
> and attempt to build Axis using RC2.  However, the
> compiler output still spits out all the "enum" errors.
>  If I switch the JAVA_HOME environment variable to the
> 1.4.2 home, Axis builds fine.
> 
> Is there some simple step I'm missing to get RC2 to
> build with 1.5?  I've been through a long thread on
> this topic from a month ago but I can't find anything
> to help.
> 
> The only reason I find myself needing 1.5 is because I
> built a whole server environment and website a month
> ago using 1.5 (figured it was the latest and greatest,
> so why not?).  Only now do I find myself needing Axis
> and I'd prefer not to switch my environment over to
> 1.4 unless there's no other way.
> 
> Regards,
> 
> JF
> 
> --- ANDREW MICONE <AMICONE@DEQ.IDAHO.GOV> wrote:
> 
> > Actually, you just need the latest 1.2RC2 (the
> > version that changed enums to constants) to get it
> > to work under J2SE1.5. It is still compiled under
> > 1.42. It sounds like you are having problems with
> > errors generated by WSDL2Java.
> >
> > By the way, unless you are using J2SE1.5 features,
> > you don't gain much in going to 1.5 over just runing
> > tomcat with the compability package installed in
> > 1.42 (assuming that's your environment). -- Andy
> >
> > >>> footh@yahoo.com 12/09/04 03:12PM >>>
> > When using Axis with java 1.5 installed I get all
> > these Unsupported major.minor version errors.  When
> > I
> > switch to any version of 1.4 I have no problems.
> >
> > So, I am guessing that I must recompile the Axis
> > source under 1.5 for it to work properly?  I've read
> > other messages of people who have successfully
> > gotten
> > Axis to work under 1.5 (lots of messages on the
> > "enum"
> > bug).  I know this solution seems obvious but I just
> > want to make sure it will work.
> >
> > Thanks,
> >
> > JF
> >
> > __________________________________________________
> > Do You Yahoo!?
> > Tired of spam?  Yahoo! Mail has the best spam
> > protection around
> > http://mail.yahoo.com
> >
> >
> 
> __________________________________
> Do you Yahoo!?
> Meet the all-new My Yahoo! - Try it today!
> http://my.yahoo.com
> 
> 


-- 
Davanum Srinivas - http://webservices.apache.org/~dims/

Mime
View raw message