axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From tony.q.wed...@gsk.com
Subject Re: java.security.AccessControlException
Date Tue, 09 Nov 2004 12:52:27 GMT
Christian,
It has been a long time since I worked with applets but I think that an 
applet can open connections with the host that served the applet. In this 
case, if the web service is hosted on the same machine as the applet, you 
should have no problems in either loading classes from the server or 
accessing web services on the server. If you want to access resources on 
the client machine or on another host, then you would have problems.
Tony



Hi again ...
Ok, I should have been done some googling before asking the mailing list.
It seems that using Axis in an applet is only possible if the jar file 
is signed. But for a signed jar file, the user must accept the 
signature, and I believe that many users will not be willing to do that 
(simply because they don't understand what all this signature stuff is 
about). Besides, my jar file is about 1.5 MB because of all the 
libraries needed by Axis. These two problems taken together bring me to 
the conclusion that Axis is not applicable for creating SOAPing applets.
So my (probably last ...) question is: Does a "lightweight" SOAP 
implementation exist, maybe as a spin-off of Axis? Wouldn't it be one of 
the first things that come to mind to create a SOAPing applet??
Perhaps this idea is worth to spend some time on it. Maybe I will start 
a project in this direction ...

Christian

Christian Schröder wrote:

> Hello!
> I have written a java applet which should talk to a server (written in 
> C++) using Axis/SOAP.
> When I launch the containing HTML page in my webbrowser, I get the 
> following stack trace in the java console:
>
> java.lang.ExceptionInInitializerError
> [...]
> Caused by: java.security.AccessControlException: access denied 
> (java.lang.RuntimePermission createClassLoader)
> [...]
>
> I have already found out that creating a file with special permission 
> and passing the name of this file as an argument to the AppletViewer 
> helps to prevent this problem when testing the applet. But what if the 
> applet should really run in a browser?
> I first thought that the problem would be solved if the server where 
> the applet is hosted and the server it tries to talk to (the SOAP 
> server) were the same. But the problem still remains.
> What can I do to get my applet running? Is it necessary that the user 
> grants some permissions? What exactly does Axis try to do that 
> conflicts with the permissions?
> I didn't find anything about this in the docs. Each hint is 
appreciated!!
>
> Christian
>





Mime
View raw message