axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Vy Ho <st946...@drexel.edu>
Subject Re: Big bug in Axis? DataHandler data is sent when making request without any parameter
Date Tue, 30 Nov 2004 16:28:50 GMT
Thanks to Roy Willy Haug, he sent me the following message which states 
that he have had the same problem and found a way around it.  I am not 
sure the way he described is the end solution to the problem or not, but 
it clearly indicates that this is indeed a bug, and should be an easy fix.

Here's the message:

Hi there,

It looks like I had the same problem as you describe. It turned out that
it was the Axis generated client-side SoapBindingStub that was in error.


Commenting out the setAttachments() and extractAttachments() in all
methods in the Axis-generated client-side SoapBindingStub.java solved
this problem for me. 

... Snip from the ...SoapBindingStub.java ...

        setRequestHeaders(_call);
        //setAttachments(_call);
        java.lang.Object _resp = _call.invoke(new java.lang.Object[]
{in0, new java.lang.Long(in1), in2.value});

... Snip from the ...SoapBindingStub.java ...


If you generate these stub-files automatically you will have to
rememeber to comment out these lines every time they are produced, or
change the script you use to do it for you. 

I do not currently subscribe to the Axis mail list, and found no way to
answer directly to the list. Please feel free to provide this
information to the Axis list. 

Regards, 

Roy Willy Haug



Mime
View raw message