axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Jia Yiyu" <yy...@nowmediatech.com>
Subject RE: HashMap problem
Date Fri, 15 Oct 2004 16:06:52 GMT

I posted one message for passing java.util.Hashtable object as parameters of
Web service days ago. In my case, I got wrong object type casting error
message. I noticed that after compiling the service, the service funciton's
parameter has been changed to be HashMap instead of Hashtable. So it is ture
that Axis maybe change the parameter type.

I also noticed that two new classes were generated by Axis:
org.apache.xml.xml_soap.MapItem.java and
org.apache.xml.xml_soap.MapItem_Helper.java .

Hence I think this depends on the implementation of Axis. Because i dont
have much time to deeply study it, I just changed one Hashtable type
parameter into two Vector type parameters. Whatever it is stupid or not, I
finally I walk around this.

You will appreciated if you will post your solution after you solved the
problem.

Best regards!

	Jia Yiyu



-----Original Message-----
From: Bouche Paul [mailto:Paul.Bouche@student.hpi.uni-potsdam.de]
Sent: Friday, October 15, 2004 8:33 PM
To: axis-user@ws.apache.org
Subject: RE: HashMap problem


What kind of client do you use? What kind of service style do you use?
java.util.HashMaps are not all that interoperable.  They only work with
modifications to generated code. Does Axis maybe serialize the request is
gets in into a different object?

-- Paul

> -----Original Message-----
> From: Dalibor Dostál [mailto:Dalibor.Dostal@intax.cz]
> Sent: Mittwoch, 13. Oktober 2004 16:54
> To: axis-user@ws.apache.org
> Subject: HashMap problem
>
>
> Hello all,
>
> I need help with following problem: when invoking remote axis web
> service with Hashmap argument, from time to time it doesn´t succeed
> on remote side with this message
>
> java.lang.IllegalArgumentException: object is not an instance of
> declaring class
> 20041013 15:07:23 [S]VFRA: Tried to invoke method public
> java.util.HashMap
> WebSluzbyFlat.zpracujPozadavek(java.util.HashMap) with
> arguments java.util.HashMap.
> The arguments do not match the signature.; nested exception is:
> java.lang.IllegalArgumentException: object is not an instance of
> declaring class
>
> We are using java 1.3.1 and axis 1.2RC1 on AIX 4.3.3.
>
> Thanks in advance
>
> Dalibor Dostál
>

.


Mime
View raw message