axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Hubble, Christopher" <CHRISTOPHER.L.HUB...@saic.com>
Subject RE: 2 way SSL with Axis and Tomcat as a Service
Date Tue, 12 Oct 2004 12:57:34 GMT
I pretty much used this guide (and the new chapter it links to) to do it.

http://www.pankaj-k.net/WSOverSSL/WSOverSSL-HOWTO.html

Pretty much everything you need to know is in the SSL section of the new
chapter.  It starts on page 16 of the pdf.  You gen your keystores and
truststores, making sure to place them on the appropriate machines.  Then
change server.xml.  I didn't use JCEKS and all of my stuff works.  The hard
part was installing Tomcat as a service with the truststore attribute set.
For some reason, Tomcat doesn't let you set it in server.xml.  Then you just
modify your client to use https and include the keystore and truststore.
Other than a typo, the CL version worked perfectly.  I had to just play
around with tomcat.exe to get it installed as a service, tho.

Chris

-----Original Message-----
From: Silvano Maffeis [mailto:silvano@pyx.ch]
Sent: Tuesday, October 12, 2004 2:30 AM
To: axis-user@ws.apache.org
Subject: Re: 2 way SSL with Axis and Tomcat as a Service


Hubble, Christopher wrote:

>Welp, after much trial and tribulation, I finally got axis using 2 way ssl.
>This required me to custom set up tomcat as a service, and I finally got
>that working.  Once I get my code all cleaned up, I'll post the relavent
>details.
>
>Chris
>  
>
That would be much appreciated, thanks :-)

Silvano

Mime
View raw message