axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Arijit Mukherjee" <>
Subject RE: IncompatibleClassChangeError in Axis-1.2-RC1
Date Thu, 14 Oct 2004 08:07:59 GMT
I did that (using all of them together) - but that didn't fix my
problem. Finally, I cracked it -  I had to place the jaxrpc and saaj jar
files in $CATALINA_HOME/common/lib - then it worked. Previously, the
versions in that folder and the one in actual webapps/axis/WEB-INF/lib
were not matched.


>-----Original Message-----
>From: Jeff Greif [] 
>Sent: 14 October 2004 09:04
>Subject: Re: IncompatibleClassChangeError in Axis-1.2-RC1
>I was getting exactly the same exception.  The problem went 
>away when I made sure that the versions of axis.jar, saaj.jar, 
>xercesImpl.jar and xmlParserAPIs.jar from the Axis-1.2RC1 
>package were all used together.  The last thing I fixed before 
>succeeding was to make sure that RC1's version of ssaj.jar was 
>not superseded by some other version in my classpath. (I had 
>additional complications of using wsif and having to get that 
>to work with all these jars also.)
>----- Original Message -----
>From: "Arijit Mukherjee" <>
>To: <>
>Sent: Thursday, October 14, 2004 12:31 AM
>Subject: RE: IncompatibleClassChangeError in Axis-1.2-RC1
>Hi Jeff
>So have you solved this? Did new versions of saaj and xerces get rid of
>this problem? I already have the new version of saaj (I mean the one
>that comes with RC1) - do I need to change that?
>>-----Original Message-----
>>From: Jeff Greif []
>>Sent: 13 October 2004 20:33
>>Subject: Re: IncompatibleClassChangeError in Axis-1.2-RC1
>>I just spent yesterday struggling with this.  I believe it is
>>caused by needing a new version of saaj.jar (the one that
>>comes with Axis-1.2RC1) (and maybe the xerces jars also.)
>>----- Original Message -----
>>From: "Arijit Mukherjee" <>
>>To: <>
>>Sent: Wednesday, October 13, 2004 12:29 PM
>>Subject: IncompatibleClassChangeError in Axis-1.2-RC1
>>I am working on a document oriented Web Service which was originally
>>developed with Axis-1.2-beta2, and still works with that. Recently, I
>>tried to use the new Axis-1.2-RC1, and I am getting a problem while
>>trying to use the service. The service gets deployed under tomcat
>>5.0.28, and the wsdl can be accessed in the browser, but any
>>call to the
>>service fails with the following error:
>> at

View raw message