axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Brian H. Ward" <glyphri...@gmail.com>
Subject Re: NoClassDefFound: Software, part II (sorry ...)
Date Tue, 28 Sep 2004 21:35:44 GMT
Try 'java -cp %AXISCLASSPATH%;%CLASSPATH% ....'


On Tue, 28 Sep 2004 18:08:08 +0200, Axel Bock <news-and-lists@the-me.de> wrote:
> Hi again,
> 
> just to be sure I did the complete installation (tomcat & axis), and I still
> get this error when I try to create a WSDL from a Java class. This time I used
> Axis 1.2beta for testing whether this might actually help ... .
> 
> My environment looks as follows:
> 
> CLASSPATH=.;C:\Programme\J2EE_SDK\jdk\lib\tools.jar // qt removed from that
> JAVA_HOME=C:\Programme\J2EE_SDK\jdk
> 
> AXIS_HOME=C:\Programme\Apache Software Foundation\Axis1.2b
> AXIS_LIB=%AXIS_HOME%\lib
> AXISCLASSPATH=%AXIS_LIB%\axis.jar;
> ..%AXIS_LIB%\commons-discovery.jar;
> ..%AXIS_LIB%\commons-logging.jar;
> ..%AXIS_LIB%\jaxrpc.jar;
> ..%AXIS_LIB%\saaj.jar;
> ..%AXIS_LIB%\log4j-1.2.8.jar;
> ..%AXIS_LIB%\xml-apis.jar;
> ..%AXIS_LIB%\xercesImpl.jar
> ..%AXIS_LIB%\wsdl4j.jar (without these ".." of course :)
> 
> TOMCAT_HOME=C:\Programme\Apache Software Foundation\Tomcat 5.0
> CATALINA_HOME=%TOMCAT_HOME%
> 
> I have copied the JAF framework into %TOMCAT_HOME%\webapps\axis\WEB-INF\lib.
> I have copied the xerces parser files (taken from tomcat) in the same
> directory, as well as in %AXIS_LIB%. (if it's needed - why doesn't the doc
> mention it?)
> 
> I have also searched *EVERY* .jar file for something called "Software", AND I
> have searched the JDK tree as well as the tomcat/axis tree for a *file* having
> the string "software" in its name. Nada.
> 
> Tomcat _seems_ to run fine, at least I get no errors, and the
> axis-happiness-page only complains about optional components (mail,
> attachments) missing.
> 
> The code of my - very, very simple - web service is attached. When I try to
> create a WSDL file from the Java code (as described here:
> http://java2simple.blog-city.com/read/162200.htm) with the command:
> 
>        java -cp %AXISCLASSPATH% -cp %CLASSPATH% \
>                org.apache.axis.wsdl.Java2WSDL \
>                -o wstest.wsdl  \
>                -l http://localhost:8080/axis/services/wstest \
>                -n urn:wstest -p"wstest" \
>                wstest.WsTest
> 
> ... I get my beloved error:
> 
>        Exception in thread "main" java.lang.NoClassDefFoundError: Software
> 
> I don't know what to do. Really. I am sorry to post this message again, but
> this time I thought I might include every detail, so someone more experienced
> might spot instantly what I'm doing wrong   :-)) .
> 
> Well. Thanks in advance anyways, greetings & ciao,
> 
> Axel.
> 
> ----------- code -----------
> 
> IWsTest.java:
> 
> package wstest;
> public interface IWsTest {
>        public String sayHello(String Hello);
> }
> 
> WsTest.java:
> 
> package wstest;
> public class WsTest implements IWsTest {
>        public String sayHello(String Hello)
>        {
>                return "";
>        }
> }
> 
>

Mime
View raw message