axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Ivan Vasquez" <i...@itos.uga.edu>
Subject Axis 1.2: Server.userException - java.lang.ClassCastException
Date Mon, 13 Sep 2004 05:44:37 GMT
I'm migrating an Axis 1.1 Web service to 1.2, but I'm already at a loss. The installation is
OK, stock quote sample works fine, but every time I want to run my own service, I send:

<?xml version="1.0" encoding="UTF-8"?>
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
 <soapenv:Body>
  <ns1:beginTransaction soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
xmlns:ns1="urn:coordinator">
   <ns1:transactionProtocol href="#id0"/>
  </ns1:beginTransaction>
  <multiRef id="id0" soapenc:root="0" soapenv:encodingStyle="http://schemas.xmlsoap.org/soap/encoding/"
xsi:type="xsd:int" xmlns:soapenc="http://schemas.xmlsoap.org/soap/encoding/">1</multiRef>
 </soapenv:Body>
</soapenv:Envelope>

And always get...

<?xml version="1.0" encoding="utf-8"?>
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
 <soapenv:Body>
  <soapenv:Fault>
   <faultcode>soapenv:Server.userException</faultcode>
   <faultstring>java.lang.ClassCastException</faultstring>
   <detail/>
  </soapenv:Fault>
 </soapenv:Body>
</soapenv:Envelope>

Can you point out where is this exception coming from (client, server)? I even did a brand
new Tomcat/Axis install, checked my $CLASSPATH and no luck. I get the same error using WSIF
or org.apache.axis.client.Call.

When I tried 1.2Alpha I remember having problems with soapenc (e.g. type="soapenc:string"),
I don't know if this time it might be the same.

Thanks in advance.
IVan.



Mime
View raw message