axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Barlotta, Timothy - Arlington, VA - Contractor" <Timothy.Barlo...@usps.gov>
Subject RE: How to add AXIS to Web Sphere 5.1
Date Tue, 17 Aug 2004 13:12:59 GMT
I am using Axis inside WebSphere 5.1 with a custom application, I
deployed as an .ear file.  You do not need to do anything special to get
it working.  

The only thing I can think that you might want to check is your web.xml
file.  Have you mapped the axis servlet correctly?  Something like:
	<servlet>
		<servlet-name>AxisServlet</servlet-name>
		<display-name>Apache-Axis Servlet</display-name>
	
<servlet-class>org.apache.axis.transport.http.AxisServlet</servlet-class
>
	</servlet>
	<servlet-mapping>
		<servlet-name>AxisServlet</servlet-name>
		<url-pattern>/services/*</url-pattern>
	</servlet-mapping>

It has been a while since I ran any of the test code, sorry if it
doesn't help.

HTH,
Tim

> -----Original Message-----
> From: Mahen Perera [mailto:mahens@gmail.com] 
> Sent: Tuesday, August 17, 2004 8:02 AM
> To: axis-dev@ws.apache.org; axis-user@ws.apache.org
> Subject: How to add AXIS to Web Sphere 5.1
> 
> 
> Hi 
> 
> I want to use the AXIS SOAP engine in Web Sphere, instead of 
> the built in SOAP engine provided by Web Sphere.
> 
> To do this,
> 
> I deployed AXIS as a normal Web Application (i.e packaging 
> the webapps\axis folder in the AXIS 1.1 distribution in to a 
> WAR file called axis.war and deploying this WAR file using 
> the Admin Console of Web Sphere - used default settings).
> 
> When the context root was requested in deploying the WAR file 
> , i used "axis" as the Context root
> 
> After deploying, i tried to access the 
> <serverName>:port/<context Root>
> 
> But did not get the AXIS Welcome page...
> 
> Can someone pls help in sorting this out....
> 
> Do i have to do any configurations when deploying the WAR 
> file ,,,, or ...???
> 
> Mahen
> 

Mime
View raw message