axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Robert Bateman <bobbate...@sequoiallc.com>
Subject Another newbie SOAPMonitor problem
Date Fri, 06 Aug 2004 13:18:11 GMT
Apologies if this has been asked and answered!


I have been asked to integrate Axis 1.2 into a web application that is 
currently under development.  I've downloaded beta 3 and gone thru the 
integration docs to include Axis into the application.  The preliminary 
testing of Axis indicates the handler and service are up and operating.

However, when I attempt to load SOAPMonitor I'm getting an error - not at the 
server, but at the client:  Class not loaded SOAPMonitorApplet.class

Being that I've been debugging problems with our code, I tried loading the 
WEBAPPS/Axis folder directly into Tomcat and restarting.  I verified that 
Axis was up and running by connecting to http://localhost:8080/axis.  I also 
verified that I have everything correct via happyaxis.jsp.  Loading 
SOAPMonitor here fails too for the same reason  :(

Doing a trace of java at the client, I saw the following:

Connecting http://localhost:8080/home/SOAPMonitorApplet.class with no proxy
INFO: Connecting http://localhost:8080/home/SOAPMonitorApplet.class with no 
proxy
Connecting http://localhost:8080/home/SOAPMonitorApplet/class.class with no 
proxy
INFO: Connecting http://localhost:8080/home/SOAPMonitorApplet/class.class with 
no proxy
load: class SOAPMonitorApplet.class not found.

In both my .war and in the axis webapps versions, SOAPMonitorApplet.class and 
the other needed classes are stored in the WEB-INF/classes folder.  I'm not 
sure if I've done something wrong or not.  Can anyone advise?

Bob


Mime
View raw message