axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Fabien Marsaud <fabien.mars...@steria.com>
Subject NoSuchMethodException on BeanSerializeFactory.create
Date Tue, 24 Aug 2004 14:46:57 GMT
Hi everyone

I am trying ot access some webservices.
I WSDL2Javaed the WSDL i wanted, made a project using Axis 1.2beta, including its 8 jars +
the activation, mail, commons-logging, dom, sax, xalan, xercesimpl jars.

First, when i instanciate a new Service(), i get the following :

------------------------------------------------------------------------------------------

<24 août 2004 16:37:14 CET> DEBUG [ProjectResourceBundle.java:264 -- getBundle] - getBundle(org.apache.axis,org.apache.axis.i18n,resource,null,...)
<24 août 2004 16:37:15 CET> DEBUG [ProjectResourceBundle.java:423 -- loadBundle] -
loadBundle: Ignoring MissingResourceException: Can't find bundle for base name org.apache.axis.resource,
locale fr_FR
<24 août 2004 16:37:15 CET> DEBUG [ProjectResourceBundle.java:318 -- getBundle] - Created
org.apache.axis.i18n.resource, linked to parent null
<24 août 2004 16:37:15 CET> DEBUG [ProjectResourceBundle.java:264 -- getBundle] - getBundle(org.apache.axis,org.apache.axis.utils,resource,null,...)
<24 août 2004 16:37:15 CET> DEBUG [ProjectResourceBundle.java:423 -- loadBundle] -
loadBundle: Ignoring MissingResourceException: Can't find bundle for base name org.apache.axis.utils.resource,
locale fr_FR
<24 août 2004 16:37:15 CET> DEBUG [ProjectResourceBundle.java:423 -- loadBundle] -
loadBundle: Ignoring MissingResourceException: Can't find bundle for base name org.apache.axis.resource,
locale fr_FR
<24 août 2004 16:37:15 CET> DEBUG [ProjectResourceBundle.java:328 -- getBundle] - Root
package not found, cross link to org.apache.axis.i18n.resource
<24 août 2004 16:37:15 CET> DEBUG [ProjectResourceBundle.java:328 -- getBundle] - Root
package not found, cross link to org.apache.axis.i18n.resource
<24 août 2004 16:37:15 CET> DEBUG [ProjectResourceBundle.java:72 -- handleGetObject]
- org.apache.axis.i18n.resource::handleGetObject(engineConfigLoadFactory)
<24 août 2004 16:37:15 CET> DEBUG [EngineConfigurationFactoryFinder.java:206 -- newFactory]
- Factory org.apache.axis.configuration.EngineConfigurationFactoryServlet Ignored: unable
to load/resolve class.
<24 août 2004 16:37:15 CET> DEBUG [ProjectResourceBundle.java:72 -- handleGetObject]
- org.apache.axis.i18n.resource::handleGetObject(engineFactory)
<24 août 2004 16:37:15 CET> DEBUG [EngineConfigurationFactoryFinder.java:141 -- run]
- Got EngineFactory: org.apache.axis.configuration.EngineConfigurationFactoryDefault
<24 août 2004 16:37:15 CET> DEBUG [AxisEngine.java:148 -- init] - Enter: AxisEngine::init

------------------------------------------------------------------------------------------

Seems there are things missing. But maybe not as i'm using only some part of Axis. So is it
normal ?

After that, i fill my structures and call the service i want. And then, i get a load of exceptions
and traces :

------------------------------------------------------------------------------------------

<24 août 2004 16:37:45 CET> DEBUG [OperationDesc.java:154 -- setReturnType] - @9fd062setReturnType({http://opcfoundation.org/webservices/XMLDA/1.0/}>GetPropertiesResponse)
<24 août 2004 16:37:45 CET> DEBUG [ProjectResourceBundle.java:72 -- handleGetObject]
- org.apache.axis.i18n.resource::handleGetObject(transport00)
<24 août 2004 16:37:45 CET> DEBUG [Call.java:2035 -- setTransport] - Transport is org.apache.axis.transport.http.HTTPTransport@1e5cf0
<24 août 2004 16:37:45 CET> DEBUG [ProjectResourceBundle.java:72 -- handleGetObject]
- org.apache.axis.i18n.resource::handleGetObject(exception00)
<24 août 2004 16:37:45 CET> DEBUG [BaseSerializerFactory.java:241 -- createFactory]
- Exception:
java.lang.NoSuchMethodException: org.apache.axis.encoding.ser.BeanSerializerFactory.create(java.lang.Class,
javax.xml.namespace.QName)
 at java.lang.Class.getMethod(Class.java:978)
 at org.apache.axis.encoding.ser.BaseSerializerFactory.createFactory(BaseSerializerFactory.java:234)
 at org.apache.axis.client.Call.registerTypeMapping(Call.java:2229)
 at org.opcfoundation.webservices.XMLDA._1_0.ServiceStub.createCall(ServiceStub.java:560)
 at org.opcfoundation.webservices.XMLDA._1_0.ServiceStub.getStatus(ServiceStub.java:575)
 at .................................

 ------------------------------------------------------------------------------------------

the funny thing is that the service does answer at the end. So it doesn't seem to be a critical
error at all.

Has any of you an idea on why there is this NoSuchMethodException on the BeanSerializerFactory.create
(ah yes, it seems BeanSerializerFactory has no create method....so ok, and then ?), and how
to get around it ?

Thanks.

fabien.
Mime
View raw message