axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "THOMAS, JAI [AG-Contractor/1000]" <jai.tho...@monsanto.com>
Subject RE: deployment problems
Date Fri, 30 Jul 2004 14:19:26 GMT
As step 1, I would open up server-config.wsdd under web-app and see your services are listed.
 
Jai

-----Original Message-----
From: rory galvin [mailto:roryg2001@hotmail.com]
Sent: Thursday, July 29, 2004 11:54 AM
To: axis-user@ws.apache.org
Subject: deployment problems





Hey guys,

I'm having basic trouble deploying my own webservice on axis. I've followed all of the given
examples and haven't had any trouble with them so far... until I wrote my own. The problem
occurs when I go to view my deployed service on http://joni.cs.tcd.ie:8080/axis/servlet/AxisServlet
<http://joni.cs.tcd.ie:8080/axis/servlet/AxisServlet> . My web service isn't listed
for some odd reason.

These are the steps i been taking taking.

Step 1: deploy using the admin client

--> java org.apache.axis.client.AdminClient deploy.wsdd 

After which I get returned <Admin>Done processing</Admin>

"""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""

"""""""""""""""""""""""My deploy.wsdd"""""""""""""""""""""""""""""""

<deployment xmlns="http://xml.apache.org/axis/wsdd/"

xmlns:java="http://xml.apache.org/axis/wsdd/providers/java">

<service name="OntologyDataExtractor" provider="java:RPC">

<parameter name="className" value="com.trinity.webservices.swoogle.OntologyDataExtractor"/>

<parameter name="allowedMethods" value="*"/>

<beanMapping qname="myNS:Swoogle" xmlns:myNS="urn:SwoogleService"

languageSpecificType="java:com.trinity.webservices.swoogle"/>

</service>

</deployment>

""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""""

Step 2: I've also added my class files to the classes folder under the axis directory

classes->com->trinity->webservice->swoogle->OntologyDataExtractor

AXIS IS TELLING ME THAT THE SERVICE HAS BEEN DEPLOYED BUT IT CLEARLY HASN'T BEEN. CAN ANYONE
TELL ME WHY THIS IS AND HOW I MIGHT RESOLVE THE PROBLEM.

Regards,

Rory..

 

 

 

 


  _____  

STOP MORE SPAM with the new  <http://g.msn.com/8HMAEN/2728??PS=47575> MSN 8 and get
2 months FREE*


Mime
View raw message