axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From Baiss Eric Magnusson <ba...@mac.com>
Subject Get past Axis logging problem
Date Sun, 11 Jul 2004 01:03:53 GMT
Can anyone think of a way to get past the logging problems I am having 
with Axis?

I get a NoClassDefError on the following line
	private static Log log = LogFactory.getLog( 
BasicHandler.class.getName() );
of BasicHandler.java

I have determined that Axis will not read <log4j.properties> on my 
server no matter where I put the file, nor does it say it is failing to 
read it, but maybe that's by design.

I think if I could just get past the logging error that the service 
would run.

I have tried with both straight calls to Axis and calls using Apple's 
WOWebService package, both methods end up at the same error.

I'm about at the point where I think it cannot be fixed with MacOSXS 
10.2, for some reason there must be a reason
Axis requires 10.3, because that is what is on my development machine 
and the WebService call works fine in that environment.
----
Baiss Eric Magnusson
<http://www.Track-Your-Finances.com>
<http://www.CascadeWebDesign.com>


Mime
View raw message