axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From NY...@aol.com
Subject Re: JUnit Test Case with Axis
Date Tue, 22 Jun 2004 09:21:53 GMT
 
I can get TCPMon to monitor messages now but JUnit still does not work.  
Listenng on 8081 to 8080
 
In a message dated 6/22/2004 9:11:07 AM Eastern Standard Time,  
MeloroJ@Pragmatics.com writes:

Are TCPMon and your web server running on  the same machine?
 
What port is your webserver listening  on?

-----Original Message-----
From: NYY96@aol.com  [mailto:NYY96@aol.com]
Sent: Monday, June 21, 2004 5:20  PM
To: axis-user@ws.apache.org
Subject: JUnit Test Case  with Axis


I attempt to execute the JUnit Test Case generated by WSDL2Java and I  
receive the following error:
 
java.lang.NoClassDefFoundError: ReportHandlerServiceTestCase (wrong  name:  
localhost/axis/services/ReportHandlerServicePort/ReportHandlerServiceTestCase)

I have deployed the service into axis successfully and am able to  
successfully use a client to send a request SOAPEnvelope and return a  response 
appropriately. 
 
I am trying to use TCPMon and JUnit to now see if the service actually  does 
anything meaningful (Other than produce the envelopes great) and I  cannot get 
either to work. TCPMon says "Waiting for ConnectiON" and never  stops saying 
that no matter how many times I run the service on port  8080.
 
JUnit gives me that aforementioned error.
 
Would anybody be willing to help me? Thanks,
James Crosson
 




 

Mime
View raw message