axis-java-user mailing list archives

Site index · List index
Message view « Date » · « Thread »
Top « Date » · « Thread »
From "Daniel Perry" <d.pe...@netcase.co.uk>
Subject axis standalone http server (using non jws services)
Date Wed, 30 Jun 2004 11:06:39 GMT
Hi,
I'm trying to use the internal axis http server (java) and deploy a web
service to it.

If i put my service on as a jws file, it all works fine:
http://localhost:3893/SoapService.jws?wsdl
it gives me the expected wsdl.

However if i try and use the service:
http://localhost:3893/services/xfr?wsdl
I get an error:

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"
xmlns:xsd="http://www.w3.org/2001/XMLSchema"
xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
- <soapenv:Body>
- <soapenv:Fault>
  <faultcode
xmlns:ns1="http://xml.apache.org/axis/">ns1:Server.NoService</faultcode>
  <faultstring>The AXIS engine could not find a target service to invoke!
targetService is null</faultstring>
- <detail>
  <ns2:stackTrace xmlns:ns2="http://xml.apache.org/axis/">AxisFault
faultCode: {http://xml.apache.org/axis/}Server.NoService faultSubcode:
faultString: The AXIS engine could not find a target service to invoke!
targetService is null faultActor: faultNode: faultDetail: The AXIS engine
could not find a target service to invoke! targetService is null at
org.apache.axis.server.AxisServer.generateWSDL(AxisServer.java:492) at
org.apache.axis.transport.http.SimpleAxisWorker.run(SimpleAxisWorker.java:33
7) at java.lang.Thread.run(Unknown Source)</ns2:stackTrace>
  </detail>
  </soapenv:Fault>
  </soapenv:Body>
  </soapenv:Envelope>

My server-config.wsdd is as follows:

<?xml version="1.0" encoding="UTF-8"?>
<deployment name="defaultClientConfig"
xmlns="http://xml.apache.org/axis/wsdd/"
xmlns:java="http://xml.apache.org/axis/wsdd/providers/java"
xmlns:handler="http://xml.apache.org/axis/wsdd/providers/handler">
<globalConfiguration>
<parameter name="sendMultiRefs" value="true"/>
<parameter name="sendXsiTypes" value="true"/>
<parameter name="attachments.implementation"
value="org.apache.axis.attachments.AttachmentsImpl"/>
<parameter name="sendXMLDeclaration" value="true"/>
<parameter name="axis.sendMinimizedElements" value="true"/>
<requestFlow>
<handler type="java:org.apache.axis.handlers.JWSHandler">
<parameter name="scope" value="session"/>
</handler>
<handler type="java:org.apache.axis.handlers.JWSHandler">
<parameter name="scope" value="request"/>
<parameter name="extension" value=".jwr"/>
</handler>
</requestFlow>
</globalConfiguration>
<handler type="java:org.apache.axis.handlers.http.URLMapper"
name="URLMapper"/>
<handler type="java:org.apache.axis.transport.local.LocalResponder"
name="LocalResponder"/>
<handler type="java:org.apache.axis.handlers.SimpleAuthenticationHandler"
name="Authenticate"/>
<service name="xfr" provider="java:RPC">
<parameter name="allowedMethods" value="*"/>
<parameter name="className" value="SoapService"/>
</service>
<transport name="http">
<requestFlow>
<handler type="URLMapper"/>
<handler type="java:org.apache.axis.handlers.http.HTTPAuthHandler"/>
</requestFlow>
</transport>
<transport name="local">
<responseFlow>
<handler type="LocalResponder"/>
</responseFlow>
</transport>
</deployment>

This config works with axis running under tomcat as a servlet.

Any ideas?

Thanks,

Daniel.


Mime
View raw message